Announcement

Collapse
No announcement yet.

Attachments problem after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments problem after upgrade

    Hello guys

    I have uploaded the forum at 3.8.4 and in fact I am not 100% sure if the problem I have was present before or after the upgrade.

    Some users could upload attachments in their posts, some not.
    As admn, I can attach and some of my staff but many others don't. I looked into the usergroups permissions and all members have the permission to attach and don't know what to do. These settings were unchanged from years and it was OK all the time just recently I have this problem.

    I registered a "testuser" and when I try to attach a small zip file, I get:
    Upload Errors testsong.zip:
    Upload of file failed.

    any advice please?

  • #2
    I have just disabled all the plugins and the problem is still there.

    Comment


    • #3
      Any advice please?

      Comment


      • #4
        Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Done it.

          Not sure if it has to do with that since some staff can attach files with no problem and nothing has ever been changed to the server level only with a PHP upgrade quite some time ago done by the provider.

          Thank you for reply.
          Last edited by DigitALL2; Sat 15th Aug '09, 8:13pm.

          Comment


          • #6
            Originally posted by Steve Machol View Post
            Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
            Can anyone help a complete newbie - vBullettin was installed completely for me by a Host provider, so i have no knowledge of where/how i find Admin CP - upload directory etc etc, i am trying to add Passive Video 2.00 and need to :-

            upload a installation into the upload directory

            install product xml

            rebuild forum info

            I need a complete idiots guide on how i do it !

            Comment


            • #7
              Harley!

              Open your own thread with your own dreams please! Do NOT highjack others! And yes, there is a good manual already.

              Comment


              • #8
                Im that much of a newbie i did,nt no how to open a new thread - apologies - and as for the manual - thought it would be easier to ask exactly what it is im wanting to do ! Any chance you can either help me or tell me how to open a new thread?

                Everybody started somewhere.
                Last edited by HarleyDavidson; Sun 16th Aug '09, 5:56am.

                Comment


                • #9
                  Originally posted by DigitALL2 View Post
                  Done it.

                  Not sure if it has to do with that since some staff can attach files with no problem and nothing has ever been changed to the server level only with a PHP upgrade quite some time ago done by the provider.

                  Thank you for reply.
                  I will still need the info in post #4 to help with this.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    The "Public phpinfo() Display Enabled" is enabled.
                    Sorry, forgot the link: privatesat.com/forum/

                    Comment


                    • #11
                      The only thing I see that could cause this is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

                      You will also need to restart Apache after making this change.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Thank you very much Steve. I'll ask the host to do it.

                        When you say: "...to point to the full path to a directory on the server that is chmod'd to 1777" , does it matter what directory like name, or location? The question may seem a little off but I am not familiar at the server level.

                        Comment


                        • #13
                          It doesn't really matter as long as it's chmod'd to 1777. However more hosts create a /tmp root directory for this.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Hello,

                            The directory tmp was set by the host. Now in PHP info is set to tmp. Just to make sure, I have also restarted the Apache. Unfortunately, the problem is still there.
                            I have overlooked again over the permissions. I have disabled the global plugins and it is still the same: Some members within the same /given usergroup can attach, some not.

                            Comment


                            • #15
                              Is there a correlation between file size and the ability to upload? If not then this is likely a problem with an add-on.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X