Announcement

Collapse
No announcement yet.

how to show the site without index.php?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • how to show the site without index.php?

    site is: http://team-ist.net/forums/index.php

    i want to shorten it to: http://team-ist.net/forums/

    i've seen it this way but can't seem to get it to show up as such

    help!

  • #2
    Originally posted by jerome829 View Post
    site is: http://team-ist.net/forums/index.php

    i want to shorten it to: http://team-ist.net/forums/

    i've seen it this way but can't seem to get it to show up as such

    help!
    That's a setting in your web server configuration. There are a large number of webservers, but for example I use for development xampp which includes apache. In my httpd.conf you'll see this:

    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
    DirectoryIndex index.php index.php4 index.php3 index.cgi index.pl index.html index.htm index.shtml index.phtml
    </IfModule>

    So if the user enters a path to a directory (which is this case), apache looks for one of those files in that directory. If it finds one, it returns that.
    IIS is configured through a windows interface, but it's the same issue. index.php has to be on the list of default files.

    You need to find the configuration file for whatever server you are running, and add index.php
    Please- I'm not tech support. Don't send your problem reports to me unless I've asked you to.

    Comment


    • #3
      i couldn't find 'httpd.conf' in mine.

      my server is: Apache version2.2.11 (Unix)

      i don't see anything labeled 'xampp' either. sorry, i'm not well-versed in things like this so if you have any additional info i'd really appreciate it

      thanks,
      jerome

      Comment


      • #4
        Try deleting the index.htm or index.html file in the 'forums' directory.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          Try deleting the index.htm or index.html file in the 'forums' directory.


          wow. that did it. was it because it was seeing the index.html AND index.php?

          either way, thank you!!!

          Comment


          • #6
            You're welcome.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X