Announcement

Collapse
No announcement yet.

Warning: fclose(): supplied argument - - anyone ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning: fclose(): supplied argument - - anyone ?

    I just recently Move my server - as well as updated to 3.8.4

    while eveyrthing seem to be working Fine .

    today i was playing around just a few days after the update -
    and when i update this happen .

    i am not sure what this error refer too .

    and how to correct it or update it or what do i need to change so it would be improve .

    many thanks in advance . - i click the related link and the atatchment is still there . and also the attahcment photo is still tehre , i do not understand what error is it but all seem to work fine , beside when i update this show .

    maybe i had not spotted the problem . or some kinda setting on my server ,




    Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/siam1/:/tmp:/usr/local/lib/php/) in [path]/admincp/misc.php on line 689

    Warning: fopen() [function.fopen]: Filename cannot be empty in [path]/admincp/misc.php on line 691

    Warning: fwrite(): supplied argument is not a valid stream resource in [path]/admincp/misc.php on line 692

    Warning: fclose(): supplied argument is not a valid stream resource in [path]/admincp/misc.php on line 693
    Processing: Attachment : (jpg) [18] (Post : [177] ) Error: Attachment Missing

    Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/siam1/:/tmp:/usr/local/lib/php/) in [path]/admincp/misc.php on line 689

    Warning: fopen() [function.fopen]: Filename cannot be empty in [path]/admincp/misc.php on line 691

    Warning: fwrite(): supplied argument is not a valid stream resource in [path]/admincp/misc.php on line 692

    Warning: fclose(): supplied argument is not a valid stream resource in [path]/admincp/misc.php on line 693
    Processing: Attachment : (jpg) [19] (Post : [177] ) Error: Attachment Missing

    Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/siam1/:/tmp:/usr/local/lib/php/) in [path]/admincp/misc.php on line 689

    Warning: fopen() [function.fopen]: Filename cannot be empty in [path]/admincp/misc.php on line 691

    Warning: fwrite(): supplied argument is not a valid stream resource in [path]/admincp/misc.php on line 692

  • #2
    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      ok here the URL

      www.siam1.com


      i am using mysql for attachment storing

      must be some error i made or some way along the line ..

      Thanks
      Last edited by siam1; Thu 13 Aug '09, 11:57pm.

      Comment


      • #4
        You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

        /home/siam1/tmp

        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes


        Also the php.ini setting for 'upload_tmp_dir' is empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5


          Thanks you so much , and it work like a charm .

          PROBLEM SOLVE .

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X