Announcement

Collapse
No announcement yet.

paid membership querie

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • paid membership querie

    Hi!

    I have just setup a forum for one of our clients. They had asked us to setup a paid membership system that allowed newly registered members to subscribe at rate of £50, then once expired the membership renewal price was just £10. I have never setup a paid membership system before and had made some initial enquiries on this thread (http://www.vbulletin.com/forum/showthread.php?p=1743529)

    I have set the site up and all user groups. The only problem i have is that the membership expiry date has passes and the user still retains the user group they upgraded to. So I’m guessing i haven’t set the paid subscription up correctly... i have setup the 30 day £50 initial member then changed the values (for testing) to 1 day and £0.01 (see attachment for my settings), then setup a new account, subscribed, but even though the date has passed the user group has not changed.

    Thanks for reading and will look forward to your advice.

    Regards - Adam
    Attached Files

  • #2
    Sorry, there is no function to do this. This requires modifying the code. We cannot officially support code modifications or forums running modified code, however you can try searching or asking for help with this over at www.vbulletin.org.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve, thanks for your reply. ill head over to vbulletin.org next, but just wanted to clarify with you before I do, that the paid subscriptions used on the forum software (with no mods) doesn’t allow the users user group to change automatically when the subscription designated time expires?... this seems a bit pointless, so I’m guessing my post above wasn’t explained very well, so I’ll try again.

      I’ve setup various user groups with various access levels.
      I’ve setup a paid subscription that entry level users (newly registered) can access.

      I then create a test account (as a free user).
      I then take out a subscription which allows me more access for the time period of 1 day.
      The access levels work.
      But after the time period has expired, the test account is still able to access the level that I desired by taking out the subscription... not the restricted free user access level that i would expect to have happened.

      What I would have expected the form software to have done is move the test user back to the original free user group so that it would make sense to subscribe to another user group for a designated time period. Otherwise what’s the point of defining a time period??
      In my original query I was told by Trevster that the forum atomically moves them back (http://www.vbulletin.com/forum/showpost.php?p=1743529&postcount=4) I hope this is the case as this is crucial to the clients requirements.

      Please can you advise – kind regards - Adam

      Comment


      • #4
        Once the subscription expires the person will be moved back to their old usergroup. Since this is only updated once per day you likely did not wait long enough for that to happen.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I’m afraid this isn’t happening. The original test account I setup has long since passed their subscription and their primary user group has not gone back to their original user group. I had setup a second test account and the expiry date passed yesterday and I’m having the same problem. It would be be much appreciated if you could shed some light on this situation for me as I am beginning to feel rather let down by this software. Regards - Adam
          Attached Files

          Comment


          • #6
            This function does work as advertised. I have been using the subscriptions feature on my forums for over 2 years without this problem. The only way this would not work is either if you have the settings wrong or you have an add-on that is causing this.

            Unfortunately I can't read that image so I don't know what it is supposed to show.

            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

            Next, disable all plugins.

            Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

            define('DISABLE_HOOKS', true);

            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

            Do you have the same problem?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X