Announcement

Collapse
No announcement yet.

User cp problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • User cp problem

    Everybody on my forums can go to there usercp, but anything with profile.php isn't working.

    I tried to edit/replace/delete my profile.php file, but it won't let me. The permissions on it is 0, I can't change that either.

    This happened right after I installed conquest system on my forums. But I removed and disabled it, and it still did the same problem..

    Any idea's on how to fix?

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Code:
       
      conquest.phpFile not recognized as part of vBulletin
      profile.phpFile not readable
      profle.phpFile not recognized as part of vBulletinScanned 58 files
      ./admincpScanned 3 files
      ./archiveScanned 54 files
      ./clientscript
      livetopic.jsFile not recognized as part of vBulletinScanned 4 files
      ./clientscript/yuiScanned 2 files
      ./clientscript/yui/animationScanned 2 files
      ./clientscript/yui/connectionScanned 2 files
      ./clientscript/yui/dragdropScanned 2 files
      ./clientscript/yui/yahoo-dom-eventScanned 2 files
      ./images/regimage/fontsScanned 130 files
      ./includes
      livetopic_hooks.phpFile not recognized as part of vBulletinScanned 19 files
      ./includes/cron
      conquestCycle.phpFile not recognized as part of vBulletinScanned 8 files
      ./includes/paymentapiScanned 8 files
      ./includes/xml
      bitfield_conquest.xmlFile not recognized as part of vBulletinScanned 91 files
      ./installScanned 10 files
      ./modcp
      And yea, I disabled plugins, and it still happened.

      Btw, thank you for the quick response.

      EDIT
      Just did the forum thing, it still didn't work.

      Comment


      • #4
        You have not reuploaded the files correctly. Otherwise you would not get this: File not readable
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I havn't reuploaded any files lately. But, i've tried deleting, renaming, changing, basically everything to profile.php, but nothing sticks. It just stay's there. What can I do? It won't let me change permissions, move the file, rename it so i can reupload another, nothing.

          Comment


          • #6
            I did a quick fix, I added the same file, but named profle.php, and replaced everything in my templates that said profile, to say profle. So, it works now, but I would really love it if profile.php worked.

            Sorryfor double post.

            Comment


            • #7
              Permissions can't be 0. User/Group/Other all have their own permission settings. Root can set those to supercede whatever the User (owner) sets the permissions to, but if you have 0 for permissions on the file, nobody other than root can change them to the appropriate permissions.

              All vBulletin files should have 755 permission access. If they have 0 and you don't have root access to the file space, get the host to chown -R the files to the appropriate user:user (if they aren't already) and to chmod -R the files to 755 (which they obviously aren't if they're set at 0)
              Anybody who says "it can't be done" will usually be interrupted by somebody who is already doing it.

              Comment


              • #8
                CP / Upgrade issues - need help!

                Iam running version 3.0.3 - I own the license. I do not have the "resources" for an official upgrade to latest version. The site runs somewhat stable except for the CP. it's completely down. Here's the message box that appears when you try to access it -

                Database error in vBulletin 3.0.3:

                Invalid SQL:
                SELECT thread.threadid, thread.forumid
                FROM thread AS thread, subscribethread AS subscribethread
                LEFT JOIN deletionlog AS deletionlog ON(deletionlog.primaryid = thread.threadid AND type = 'thread')
                WHERE subscribethread.threadid = thread.threadid
                AND subscribethread.userid = 1
                AND thread.visible = 1
                AND lastpost > 1249248994
                AND deletionlog.primaryid IS NULL

                mysql error: Unknown column 'thread.threadid' in 'on clause'

                mysql error number: 1054

                ------------------------------

                I do nothave access to my vb control panel (backend) just the admistrator's area off the main site. Can someone please HELP. I understand I will need to upgrade - I can't do it. I don't know sql or html code and until I can get the "resources" necessary to get assistance for upgrade - would like to have the CP accessible and working again.

                Please help and advise!

                Greatly appreciated!

                Dave

                Comment


                • #9
                  vB 3.0 is no longer officially supported. Please post a new thread in the appropriate forum.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol View Post
                    vB 3.0 is no longer officially supported. Please post a new thread in the appropriate forum.
                    Hi Steve,

                    I appreciate the response. I understand it is out-dated. Which forum (here) can I post this thread?

                    Thanks,
                    David

                    Comment


                    • #11
                      The vB 3.0 forum is here: http://www.vbulletin.com/forum/forumdisplay.php?f=59
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Thanks for trying to hijack my thread?

                        This problem isn't really vbulletin's fault, its my stupid host. They won't delete the file, and I can't delete the file myself. So i'm stuck using profle.php instead of profile.php =/

                        Comment


                        • #13
                          Perhaps it's just a miscommunication with the host rather than the hosts "fault". The steps to fix this are simple as I pointed out above.

                          Ask them to chown -R yourusername:yourusername all files under yourusername web hosting space, and to chmod -R everything under the directory your forum is installed in. This will take them about ten seconds and they should be happy to oblige. If not, find another host.

                          No need to delete files. No need to rename files and change code to match new file names... it's a simple permission error.
                          Anybody who says "it can't be done" will usually be interrupted by somebody who is already doing it.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X