Announcement

Collapse
No announcement yet.

Avatar Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avatar Problem

    Users can save a picture and upload it but as far as putting a link to a picture this error occurs:

    Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/flsports/:/usr/lib/php:/usr/local/lib/php:/tmp) in [path]/includes/class_upload.php on line 275

    Warning: fopen() [function.fopen]: Filename cannot be empty in [path]/includes/class_upload.php on line 281

    Help?

  • #2
    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /home/flsports/tmp

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes


    Also the php.ini setting for 'upload_tmp_dir' may be empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X