Announcement

Collapse
No announcement yet.

If I turn search on - my server overloads and crashes. Suggestions?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • If I turn search on - my server overloads and crashes. Suggestions?

    I currently have search turned off on my forums. This is the busy season in terms of traffic for my site and if I turn search on my server almost immediately overloads and crashes. Turn it back off and my loads average less than 0.5, usually more like 0.2 or 0.3

    I've been using vBulletin since 2003 and this is our current stats...

    Threads: 63,101, Posts: 2,012,614, Members: 14,145, Active Members: 1,880

    I'd say the number of simultaneous users at crash time is anywhere from 150 to 300 visitors.

    I was using vBulletin Search and I switched to Fulltext search... Didn't really notice much difference there.

    Any recommendations on which search method to use?

    Any recommendations on how to improve my experience?

    Should I be archiving threads on a yearly basis so its not searching through as large of an index? Or does that not matter?

    Any assistance will be greatly appreciated!

  • #2
    make the search only for registered users, the user can only search after 20 secs (or more) between seach queries
    while(true){
    if(
    $someone->needsHelp() && $i->canHelp()) $post->help();
    if(
    $i->findBug()) $post->bug();
    }

    Comment


    • #3
      I appreciate your reply. Unfortunately both suggestions are/were already implemented.

      I had set the time between search to 40 seconds and guests did not have the ability to use the search function.

      Any other thoughts?

      Comment


      • #4
        What do you have this set to?

        Admin CP -> vBulletin Options -> Message Searching Options -> Maximum Search Results to Return

        You might want to try lowering that number.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thank you for replying Steve. I had that set to the default 500 and I just lowered it to 100. Anything else you (or anyone) might recommend before I try turning it back on?

          Comment


          • #6
            If you still have problems after that then this could be either a server issue, or something caused by add-ons.

            Please see this thread for help with optimizing your server:

            http://www.vbulletin.com/forum/showt...threadid=70117

            Then post the requested info in a new thread in that forum.

            Also please note that we do this as a courtesy but optimizing servers is not really a part of vBulletin support.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I experienced the same issue as you around 4 million posts. Fulltext search hits its limitations rather soon.

              Time for a sphinx search, crazy fast and very, very scalable. Contact TECK (yqed.com) for a fantastic solution. Pricey, but well worth it and the last piece of search software you'll ever need.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X