Announcement

Collapse
No announcement yet.

Query regarding 'missing' avatar icons in Friends List

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Query regarding 'missing' avatar icons in Friends List

    Howdy all.

    I'm sure this is just a configuration problem on my part. For some reason, only avatars of Moderators and Administrators are visible on Friends and Contacts and on posts in Social Groups. Avatars of Members are not visible, instead a default image is displayed. This only occurs in these specific areas. Any ideas on why this is?

    Thanks.

  • #2
    Those are avatar thumbnails. Make sure the images/avatars/thumbs directory is writable (chmod 777). If you are storing custom avatars in the file system then make sure that directory is also writable. Then run this:

    Admin CP -> Maintenance -> Update Counters -> Rebuild Custom Avatar Thumbnails

    Admin CP -> Maintenance -> Update Counters -> Rebuild Avatar Thumbnails

    Comment


    • #3
      Hi Jake.

      No success. Followed instructions as below. I am manually uploading member avatars to each member profile in Admin CP and they are being stored in the database. After making 'thumbs' writable and performing two maintanence runs as outlined below, directory 'thumbs' remains empty and no avatar thumbnails were created. Still, as before, avatar thumbnails for both Moderators and Admins are being displayed fine. Please advise. Thanks muchus.

      Code:
      chmod 777 thumbs
      
      Admin CP -> Maintenance -> Update Counters -> Rebuild Custom Avatar Thumbnails
      
      Admin CP -> Maintenance -> Update Counters -> Rebuild Avatar Thumbnails

      Comment


      • #4
        Make sure those users actually have avatars. I have seen some people confuse avatars with profile pictures. These are different things.

        Comment


        • #5
          Hi Jake.

          Been running vBulletin many years. I know the different between Profile Pictures and Avatars.

          Do you have any other suggestions as to the cause of the error, or should I file a ticket report for further investigation?

          Comment


          • #6
            Please provide a link to a user profile that has this problem.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Hello Steve.

              We do not allow guest profile viewing by default. However, please find below a screenshot of a profile page. The solitary avatar thumb you see belongs to a moderator. The default "?" thumbnails belong to members.

              Comment


              • #8
                To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                Next, disable all plugins.

                Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                define('DISABLE_HOOKS', true);

                Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                Do you have the same problem?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Hi Steve.

                  Thanks for your reply. I have followed your instructions and discovered the problem still exists.

                  1. vBulletin does not detect any suspect file versions, other than my robots.txt file.
                  2. A new style created with no parent and a full browser cache clear did not resolve the problem.
                  3. I am not using any plugins.

                  Thanks in advance

                  Comment


                  • #10
                    Sorry but I'm going to need you to allow guests to view and provide a URL.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I am having a similar problem. Only admins can upload and use avatars. They will not upload for forum users. I cannot find any difference either on folder permissions or forum permissions on Avatars. Please feel free to check it out at www.jouster.com. Just sign up and give it a try. Both admins have no trouble at all. Folders have everyone and I_user accounts with write permissions.

                      Comment


                      • #12
                        Please start your own thread with all the relevant details. Thank you.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X