Announcement

Collapse
No announcement yet.

Attachment issue.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment issue.

    A lot of my members are suddenly unable to see attachments (all they see are red x's.) Seems it's happening in IE8 mostly. (I use Safari and have no issues at all).

    Is this a known issue? Any ideas to remedy it?
    Mommaville

  • #2
    Try this setting:

    Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> Send Internet Explorer 7 Compatibility Header -> Yes
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      That was already set to "yes".
      Mommaville

      Comment


      • #4
        Then if this is only happening with IE, this means you have a modification that is not compatible with that browser.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);


        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Check your attachment settings, make sure all of your attachment types have the proper mime-type.

          Comment


          • #6
            Okay I haven't tried what Steve said yet, but Zachary....when I looked in the attachment settings in the box that said mime-type, both said this:

            Content-type: unknown/unknown

            is that okay?
            Mommaville

            Comment


            • #7
              For which?

              Comment


              • #8
                Says that on both the jpg and gif (those are the only two we have).
                Mommaville

                Comment


                • #9
                  Use:

                  gif:
                  Content-type: image/gif

                  jpeg:
                  Content-type: image/jpeg

                  jpg:
                  Content-type: image/jpeg

                  Note: You can use this site to search for mime extensions:

                  http://filext.com/
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    That fixed it! Thank you so much!
                    Mommaville

                    Comment


                    • #11
                      if you having trouble downloading zip files

                      Change

                      Content-type: application/zip

                      to

                      Content-type: compressed file


                      works a treat
                      www.pleasureme.org.uk
                      www.hackable.cc

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X