Announcement

Collapse
No announcement yet.

Install - Stuck at step 2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install - Stuck at step 2

    Hi guys I'm stuck at step 2 of the install process. I've followed the manual but still get this problem:

    Step 2) Connect to the database
    Attempting to attach to database
    Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) /websites/123reg/LinuxPackage21/ce/le/st/celestialfaction.com/public_html/forums/includes/class_core.php on line 311
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.


    I use 123reg if that makes any difference?


    *Can this be moved to the correct forums please?
    Last edited by Sacred; Sat 13 Jun '09, 6:39pm. Reason: Wrong Forum

  • #2
    Did you put the correct database info and stuff inthe config file?

    This youtube video really helped me and hopefully it will help you! Good luck.

    http://www.youtube.com/watch?v=vsgDbbhE9KY

    Comment


    • #3
      I went back over with a fresh config file downloaded from here and now I get this error:

      Step 2) Connect to the database
      Attempting to attach to database
      Connect failed: unexpected error from the database.
      Error number: 1102
      Error description: Cannot use database celestialfactioncom_405436_db1
      Please ensure that the database and server is correctly configured and try again.

      Comment


      • #4
        Did you see the video? It really really helps!

        Comment


        • #5
          Originally posted by bahoginbill View Post
          Did you see the video? It really really helps!
          yeah i've watched the video but my control panel doesnt offer the options it shows.

          i'm not really sure what i've done wrong i've tried both localhost which gave the first error and cust-mysql-123-01 but it doesnt seem to make any difference. i've double checked my information for database name, user and password and all are correct.

          also my shift keys have decided to stop working and so has creating multiple characters by holding the key down

          Comment


          • #6
            Hmm try sending a support ticket to vbulletin and see what they can solve.

            Sorry i can't help you man.

            Comment


            • #7
              Originally posted by bahoginbill View Post
              Hmm try sending a support ticket to vbulletin and see what they can solve.

              Sorry i can't help you man.
              Well least I've fixed my shift keys!

              I would pick the weekend to try and make a website! I dare guess I'll be stuck till Monday when the working week starts?

              Comment


              • #8
                Originally posted by Sacred View Post
                Well least I've fixed my shift keys!

                I would pick the weekend to try and make a website! I dare guess I'll be stuck till Monday when the working week starts?
                Good luck man!

                Comment


                • #9
                  I've gone back to the start, deleted the database from my host and created a new one. I cant change the database password or name these are assigned by my host.

                  I've again got a fresh config file and entered the information again exact copy + pastes from what my host has given me and I get the following error:

                  Step 2) Connect to the database
                  Attempting to attach to database
                  Error description: mysql_connect() [function.mysql-connect]: Unknown MySQL server host 'cust_mysql_123_01' (1) /websites/123reg/LinuxPackage21/ce/le/st/celestialfaction.com/public_html/forums/includes/class_core.php on line 311
                  The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

                  Comment


                  • #10
                    Originally posted by Sacred View Post
                    I've gone back to the start, deleted the database from my host and created a new one. I cant change the database password or name these are assigned by my host.

                    I've again got a fresh config file and entered the information again exact copy + pastes from what my host has given me and I get the following error:

                    Step 2) Connect to the database
                    Attempting to attach to database
                    Error description: mysql_connect() [function.mysql-connect]: Unknown MySQL server host 'cust_mysql_123_01' (1) /websites/123reg/LinuxPackage21/ce/le/st/celestialfaction.com/public_html/forums/includes/class_core.php on line 311
                    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
                    Send a support ticket! They might be able to help you solve the problem.

                    Comment


                    • #11
                      3rd time lucky I guess! Not sure what I was doing wrong before but on creating my 3rd database and starting a 3rd fresh config file it worked

                      Thanks for your help mate!

                      Comment


                      • #12
                        Originally posted by Sacred View Post
                        3rd time lucky I guess! Not sure what I was doing wrong before but on creating my 3rd database and starting a 3rd fresh config file it worked

                        Thanks for your help mate!
                        I didn't really help a lot but anyways congratz man.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X