Announcement

Collapse
No announcement yet.

Superadmin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Superadmin

    I am the only admin account on my system, ID6. This is the very first account that I set up.

    how do I set up or make it a 'Super Admin'?

  • #2
    Super Admins should be limited to the board owner. It gives them 101% control over the board.

    However, if you still decide they need this, and a normal full admin account does not do the trick for them,

    you can go to the config.php file and set their id there.

    Comment


    • #3
      Originally posted by Floris View Post
      Super Admins should be limited to the board owner. It gives them 101% control over the board.

      However, if you still decide they need this, and a normal full admin account does not do the trick for them,

      you can go to the config.php file and set their id there.

      I am the board owner.

      Thanks, I will try that.

      Comment


      • #4
        Originally posted by Floris View Post
        Super Admins should be limited to the board owner. It gives them 101% control over the board.

        However, if you still decide they need this, and a normal full admin account does not do the trick for them,

        you can go to the config.php file and set their id there.

        how do I get to the config.php?

        I tried it in the address bar and I get nothing.

        Comment


        • #5
          ftp client

          go into the forum dir

          go inside the includes dir

          the config.php file is there.

          Comment


          • #6
            Originally posted by Floris View Post
            ftp client

            go into the forum dir

            go inside the includes dir

            the config.php file is there.

            I totally forgot about that file.

            $config['specialusers']['superadministrators'] = '1';

            I have that line in there, my admin login is ID1 but I still can't access the super admin functions.

            Do I have to change 'Specialusers' to my login?

            Comment


            • #7
              What exactly are you trying to access and what exactly is the message you receive when you try to access it?
              Kerry-Anne :)

              Twitter Blog

              www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

              Comment


              • #8
                Originally posted by peterska2 View Post
                What exactly are you trying to access and what exactly is the message you receive when you try to access it?

                I also tried editing the following line to the config.php

                $superadministrators = '1';

                It doesn't work.

                I get the following error:

                Sorry, you are not allowed to edit administrator permissions.

                If you think you should have permission to access this page, you will need to edit the $config['SpecialUsers']['superadministrators'] variable in the includes/config.php file.

                To allow the administrators to access this page, edit the variable to include the user IDs of those administrators should have access, separating each user ID with a comma, like this:

                $config['SpecialUsers']['superadministrators'] = '1,25,57';

                To allow only a single administrator to access this page, simply add that user's ID with no commas, like this:

                $config['SpecialUsers']['superadministrators'] = '1';


                My ID is 1

                User: mk1admin (id: 1)

                I also edited the config.php in the /forums/includes directory.

                Comment


                • #9
                  Remove the line you added. By default userid 1 is a super admin.

                  To check your userid, view your profile in the AdminCP. It will say your userid number on that page.
                  Kerry-Anne :)

                  Twitter Blog

                  www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

                  Comment


                  • #10
                    Originally posted by peterska2 View Post
                    Remove the line you added. By default userid 1 is a super admin.

                    To check your userid, view your profile in the AdminCP. It will say your userid number on that page.

                    Then it isn't working for me.

                    I went in to the user and searched for me, I sopied the userid

                    User: mk1admin (id: 1) That is from the top of the page.

                    $config['SpecialUsers']['superadministrators'] = '1';

                    That is the line in my config.php

                    Comment


                    • #11
                      Now it is working!!!!!


                      I am not sure if I had a carraige return after the line, but now it works.


                      Thanks for your help!

                      Comment


                      • #12
                        Are you sure that is the user that you are logged in as?

                        If you are logged in as the right user, and you are still having the same problem, please submit a support ticket with full details of exactly what you are trying to do and include your AdminCP login information and FTP information in the sensitive information field on the support form.
                        Kerry-Anne :)

                        Twitter Blog

                        www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X