Announcement

Collapse
No announcement yet.

Can’t customise profile despite having relevant permissions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can’t customise profile despite having relevant permissions

    I have edited the permissions for administrators and allowed them to customise their profile (fonts etc) but when I (an administrator) try to do this I am told I don’t have permission. The same goes for another administrator account.

    There is no option allowing me to customise my profile in my UserCP and when I click on the customise profile link in the FAQ I am told that I don’t have permission.

    Any ideas?

  • #2
    What is the exact message? Do you have your userid in this line in includes/config.php?

    $config['SpecialUsers']['undeletableusers'] = 'x';
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      The message I get when visiting the customise profile link in the FAQ section is

      “X, you do not have permission to access this page. This could be due to one of several reasons:
      1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
      2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.”


      I don’t know about having my userid in the line in includes/config.php

      $config['SpecialUsers']['undeletableusers'] = 'x';

      I didn’t install vb so I’m not sure.

      Comment


      • #4
        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X