Announcement

Collapse
No announcement yet.

Attachments - I can upload, but others can't?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments - I can upload, but others can't?

    Hi,

    I've been trying to figure this out for a coupel of days now without luck.


    I and a couple of other forums can post up pictures without any problem.

    However, the majority of other users can't upload and get an error message:

    Upload Errors
    IMG_4565.jpg:
    Upload of file failed.



    We've just changed hosting providers and the problem started after the install. The problem was in 3.7 and now in version 3.8 (latest release).

    I've created another forum account and didn't ahve any problems with uploading. Also managed to upload from another PC without any problems. Other pics are viewable.

    Also transferred the pics from the file system to teh database and back to the file system and the problem persists.

    Did a test and got this:

    file_uploads: On

    open_basedir: None

    safe_mode: Off
    upload_tmp_dir: None

    upload_max_filesize: 2.00 MB


    "No errors occurred while opening the uploaded file for reading."



    Any ideas how i resolve this?

    Thanks
    Last edited by Angelis; Tue 9th Jun '09, 10:15am.

  • #2
    The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

    You will also need to restart Apache after making this change.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Have created tmp directory but still can't upload attachements.

      file_uploads: On
      open_basedir: None
      safe_mode: Off
      upload_tmp_dir: /tmp/
      upload_max_filesize: 2.00 MB

      Could it be something else?

      Comment


      • #4
        That should be:

        /tmp


        Not:

        /tmp/

        And do you have root access to this server to make sure it exists and is chmod'd to 1777?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X