Announcement

Collapse
No announcement yet.

Error Number : 1062 - Help Please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Do you still have access to the old db? What are the MySQL versions on the old and new server?

    The only consistently reliable method of backing up and restoring a database is with shell access via telnet or ssh. This is because backing up with a PHP script like that in the Admin CP or phpMyAdmin can result in PHP timeout errors and an incomplete backup file.

    Please see the instructions here:

    Backup:
    http://www.vbulletin.com/docs/html/m...nce_ssh_backup

    Restore:
    http://www.vbulletin.com/docs/html/m...ce_ssh_restore

    If you don't have telnet or SSH access, some people have reported success with these scripts:

    MySQLDumper:
    http://www.mysqldumper.de/en/index.php

    MySQLHotxcopy:
    http://www.vbulletin.com/forum/showt...t=mysqlhotcopy

    Leave a comment:


  • bluidkiti
    replied
    Backed up via vBulletin. Restored through phpmyadmin.

    Everything was 'suppose' to be successful.

    Leave a comment:


  • Steve Machol
    replied
    This may be a bad db transfer then. How did backup and restore the database?

    Leave a comment:


  • bluidkiti
    replied
    Still doing it.

    Question - isn't there somewhere where you can turn the index off and then back on again? I am trying to remember where to do that.

    Images attached of the problem.
    Attached Files

    Leave a comment:


  • Steve Machol
    replied
    To fix this run Repair/Optimize in the Admin CP. You may need to run it more than once to fix all errors:

    Admin CP -> Maintenance -> Repair/Optimize Tables -> Check All -> Continue


    If you cannot access the Admin CP you can also use phpMyAdmin to repair tables.

    If you still have this problem after that, run this:

    Admin CP -> Maintenance -> Repair/Optimize Tables -> Fix Unique Indexes

    Leave a comment:


  • bluidkiti
    replied
    No - I don't.

    Leave a comment:


  • Shamil.
    replied
    Do you have a mod installed that has something to do with posting threads?

    Leave a comment:


  • bluidkiti
    started a topic Error Number : 1062 - Help Please

    Error Number : 1062 - Help Please

    I transferred a database from an old domain to a new domain. Now when I post a New thread or New Reply I get the following:

    Database error in vBulletin 3.8.2:

    Invalid SQL:

    INSERT INTO postlog
    (postid, useragent, ip, dateline)
    VALUES
    (107975, 'Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10', 1191301508, 1243456087);

    MySQL Error : Duplicate entry '107975' for key 1
    Error Number : 1062
    Request Date : Wednesday, May 27th 2009 @ 02:28:07 PM
    Error Date : Wednesday, May 27th 2009 @ 02:28:09 PM
    Script : http://www.yoursite.com/forums/newth...ostthread&f=24
    Referrer : http://www.yoursite.com/forums/newth...newthread&f=24
    IP Address : XXXX
    Username : XXXX
    Classname : vB_Database
    MySQL Version : 5.0.75-community-log
    It does post the post but this pops up after I hit the submit button for a New Thread or New Reply. It doesn't do this with quick reply. Any thoughts on how to fix this?
    Last edited by bluidkiti; Wed 27th May '09, 12:46pm.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X