Announcement

Collapse
No announcement yet.

Strange image upload issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange image upload issue

    I just upgraded to 3.8 and my members started complaining about not being about to upload images.

    I just tested it with a regular member account and found something very odd.

    When I upload a .png file, the upload is accepted, but in the manage attachments window it lists the file as a .jpg.

    When I upload a .jpg, I get an error message saying that the upload failed.

    Is there something that I have to do after upgrading to 3.8 to fix this problem?

    Thanks!

  • #2
    Seems silly but are you sure that the png file isn't actually like

    file.png.jpg

    Similar to how some viruses are named virus.jpg.exe etc.

    Comment


    • #3
      Someone else had a similar thread on this recently but I'll be damned if I can find it...
      Vote for:

      - *Admin Settable Paid Subscription Reminder Timeframe*
      -
      *PM - Add ability to reply to originator only*
      - Add Admin ability to auto-subscribe users to specific channel(s)
      - "Quick Route" Interface...

      Comment


      • #4
        No, it is definitely a PNG.

        Comment


        • #5
          Does VB convert images to jpg files? I uploaded a PNG, then saved it to my desktop and the name is now .jpg.

          Is this right?

          Comment


          • #6
            Is there any way to troubleshoot the message "Upload Failed" in the attachment management window? I'm looking for some sort of explanation as to why it failed.

            Comment


            • #7
              1. I believe the only way it would do that is if the image was resized.

              2. This is always a server issue. Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

              Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                www.manhattanreefs.com

                Comment


                • #9
                  The only thing I see that could cause this is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

                  You will also need to restart Apache after making this change.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    OK, that is done and the problem appears to be resolved (I still have to have members check it out).

                    Since I have never had that option filled in, is it possible that the upgrade from 3.7 to 3.8 changed the mechanism around uploads?

                    Like I said, I have never had that filled in and uploads worked just fine.

                    FYI, I am running on Windows 2003 Server with IIS.

                    Thanks.

                    Comment


                    • #11
                      There have been no changes to this function since 3.7. AFAIK Windows has always required a valid 'upload_tmp_dir'.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X