Announcement

Collapse
No announcement yet.

Help I need to reset the language phrase

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help I need to reset the language phrase

    rHelp I do need to reset the language pack to english phrase and language
    I have tried with tools.php and the vbulletin-language.xml but nothing seems working please I have an Forum running with many members online and the forum is off for 1 days now.... I need to reset the phrases and the language!!!!
    Please reply quickly!!!!


    Regards ITNM

  • #2
    It would help to know what you did and what the exact problem is.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Ok I've Upload the German language pack and then later I delete the German language pack but the german language pack replace the english phrases so I have half german phrases and half english phrases

      Thank you for your reply

      Comment


      • #4
        Try running one of these queries:

        For MySQL 4.0.x use this query:

        DELETE
        FROM phrase
        USING phrase AS p1
        LEFT JOIN phrase AS p2 ON ( p1.varname = p2.varname
        AND p2.languageid = -1 )
        WHERE p1.languageid =0
        AND p2.languageid IS NOT NULL;

        Or for MySQL 4.1.x and higher, use this query:

        DELETE
        FROM phrase AS p1
        USING phrase AS p1
        LEFT JOIN phrase AS p2 ON ( p1.varname = p2.varname
        AND p2.languageid = -1 )
        WHERE p1.languageid =0
        AND p2.languageid IS NOT NULL;


        Then run this:

        Admin CP -> Languages & Phrases -> Language Manager -> [Rebuild All Languages]
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thank you steve very appreciate it's work does it rebuild also the delete phrase? in [Rebuild All Languages]? because yesterday I try many way to solve the problem so I delete the Phrase

          Comment


          • #6
            Those instructions should restore on the English phrases.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              thank you

              On the tabs "Quick links" there is no "Edit your details" and "Your profile" and others too... I think I delete yesterday half of the phrases

              Comment


              • #8
                Did you follow those instructions? If so, another modification is causing this.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Sorry if I'm making you confusing, here I attach you a image this is what I delete yesterday night in "Phrases Manager" as I was very tired
                  Attached Files

                  Comment


                  • #10
                    Did you or did you not follow the instructions I gave you?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol View Post
                      Did you follow those instructions? If so, another modification is causing this.
                      Yes I did,
                      But I did not use any mod or anything else as I before have 1 language set as Default is English (US), and the problem exist when I install the German language packs and after I remove the German language pack, I have the problem with half English phrases and half German phrases, so after I want to solve this problem, and by mistake I delete the phrases e.x: activity, Add buddy, etc..

                      Thanks

                      Comment


                      • #12
                        So you still have half Gernan phrases? You picture does not show that.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by Steve Machol View Post
                          So you still have half Gernan phrases? You picture does not show that.

                          No I mean before not now because now it's work great! but some phrases word's are missing

                          Comment


                          • #14
                            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                            Next, disable all plugins.

                            Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                            define('DISABLE_HOOKS', true);

                            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                            Do you have the same problem?
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Originally posted by Steve Machol View Post
                              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                              Next, disable all plugins.

                              Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                              define('DISABLE_HOOKS', true);

                              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                              Do you have the same problem?
                              OK steve thank you for spending your time to me, now I see the problem, the problem is because of the Theme Version

                              Here I attach you an Image of the dafault theme
                              Attached Files

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X