Announcement

Collapse
No announcement yet.

Attachments problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments problem

    hi
    forum some users get an error when you add Attachments in time. I did some research on the forum but could not find the answer. information below.
    plugin folder: root /eklenti/ (777)
    bug: File system directory is not writable.
    test results in this way,

    Pertinent PHP Settings
    file_uploads:On
    open_basedir:None
    safe_mode:Off
    upload_tmp_dir:None
    upload_max_filesize:20MB
    Results:No errors occurred while opening the uploaded file for reading.


    I need to do step by step how to do that too if you tell
    good work



  • #2
    The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

    You will also need to restart Apache after making this change.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

      You will also need to restart Apache after making this change.
      Thank you for you are informed Steve. A problem and will now open on the server xcache installed. I have not made any arrangements alone vBulletin. What should I do when I have no idea about. If you appreciate the help. Thanks

      Comment


      • #4
        Since i have similiar problem, i'll write in this thread.

        there's no problem in admin CP diagnostics.
        file_uploads: on
        open_basedir: none
        safe_mode: off
        upload_tmp_dir: /var/www/vhosts/tibiaspy.com/subdomains/forum/httpdocs/tmp
        upload_max_filesize: 12.00 MB

        No errors occurred while opening the uploaded file for reading.
        all needed directories are CHMODed to 777, including this tmp dir, but still i get error
        "Could not create file system directory to hold your attachment."

        Also, why directories like "attachments" are not by default with download of vB? It took me some time to find out how should such directories be called.

        Comment


        • #5
          Upload Errors avatar4989_6.gif:
          File system directory is not writable.
          tmp folder, I did in 1777. Tmp to have another one, again in 1777 did not.

          Comment


          • #6
            hi,
            i've see this error only forum moderator other all user can upload attachment without any problem , what can I do?

            Comment


            • #7
              This is the issue: File system directory is not writable.

              Are you stroing attachments in the file system or database?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                attachments stored in the file system

                Comment


                • #9
                  Then you need to chmod the attachment directory recursively, i.e.,

                  chmod -R 777 attachment_directory
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X