Announcement

Collapse
No announcement yet.

Can't upload attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't upload attachments

    It's been many years since I last setup a new board so I am a bit rusty.
    I installed a 3.8.2 board on the weekend. Everything went fine and I've got it looking about right and accepting posts and replies.

    However I can't add an attachment.

    I've been tring to add a .jpg 124,000 803x600 and everytime I get a upload failed message. I've tried a couple other files that also failed. I have the .jpg parameters set to size of 1000x1000 and 2,000,000.

    I am the admin and as far as I can tell permissions are set properly.
    Is there another master nswitch in VB to enable attachments nthat I missed or is there possibly a server setting that is blocking me ?

    Thanks

    Steve

  • #2
    What happens when you try the Upload diagnostics?

    Admin CP -> Maintenance -> Diagnostics -> Upload

    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      This is the result of the diagnostic upload. I have turned on the php info.
      the site can be found at
      Attachments are set to go into database I don't under stand the test result "no local file found" I tried .doc and .jpeg and .jpg all with same result. The files tried are all on my local desktop and open properly. Thanks Steve

      file_uploads:On
      open_basedir:None
      safe_mode:Off
      upload_tmp_dir:None
      upload_max_filesize:2.00 MB
      Results No file uploaded and no local file found. The test cannot continue.
      Last edited by Sownman; Mon 25th May '09, 8:51pm.

      Comment


      • #4
        The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

        You will also need to restart Apache after making this change.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

          You will also need to restart Apache after making this change.
          It sounds as though you are talking about having the atachments saved
          in a directory or file system ? I want them in the DB. Am I misunderstanding ?
          If attachments are pointed to a upload_tmp_dir that is modded 777 how do they get
          from there to the DB ?

          Steve

          Comment


          • #6
            Not necessarily. The system needs a temporary location to upload attachments to, regardless of whether the final location is the database or file system.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Steve,

              I just took another look at my other installation (years old) on a different host and the diagnostic show'd same settings. Temp dir=None yet it works fine. I am still running 3.6.8 there and on a different host as well.

              Steve

              Comment


              • #8
                Different systems have different requirements. As I said this is the most likely cause of that problem. And one way or another this is a server issue,.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  This didn't solve the problem. Host said they gave our website its on php_ini and created a temp folder but no image upload works. What do I try next ?

                  Steve R

                  Comment


                  • #10
                    My guess is that they did not do what they said. Please repeat the steps in post #2 and report the results.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Hi Steve...

                      Current result....

                      file_uploads:On
                      open_basedir:None
                      safe_mode:Off
                      upload_tmp_dir:/tmp
                      upload_max_filesize:2.00 MB

                      Results No file uploaded and no local file found. The test cannot continue.

                      Comment


                      • #12
                        The error means that there is no root /tmp directory on this server or that it is not chmod'd to 1777. Only your host can create that directory. This is not within your control.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Thanks Steve I'll go back to them again.

                          Steve R

                          Comment


                          • #14
                            Thanks Steve they got it correct now. Everything OK.

                            Steve

                            Comment


                            • #15
                              Glad to hear it.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X