Hello,

To disable topic preview feature simply go to AdminCP->Settings->Options->Forum Display Options (forumdisplay)
scroll down to Length of Topic Preview Text and set it...