Announcement

Collapse
No announcement yet.

3.8.2: 404/page not found errors when making _some_ posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.8.2: 404/page not found errors when making _some_ posts

    Since upgrading to vBulletin 3.8.2, some users of my site (http://www.cyburbia.org/forums) and I are finding they get occasional "page not found" errors when posting some messages. Reloading the thread and reposting doesn't help, but I found through the process of elimination and constant reediting, removing a paragraph, sentence or even letter in a certain location allows the message to be posted. It seems if a certain character is in a certain place in the post -- and it's different for every post that causes vBulletin to choke -- the post doesn't go through, and the user gets a 404.

    An example: this is a post that I made under 3.8.1.

    http://www.cyburbia.org/forums/showthread.php?t=36609

    I can't edit it, move it or repost it in 3.8.2, though: 404. If I remove the "Other US sites" section of the post though, there's no problem.

    http://www.cyburbia.org/forums/showt...172#post490172

    The post is much shorter than the maximum length for posts set in the control panel. The post does not contain any oddball Unicode characters. There's just something in that paragraph that is causing vBulletin to choke. I found the same thing in some other posts that would go 404. In one post I recently made, I narrowed it down to the letter "o" in a certain word. I replaced the "o" with a Cyrillic lookalike character, and the post went through.

    Users of all groups are reporting problems: moderators and normal users.

    Tried repairing the database, and performing EVERYTHING in the admin maintenance menu. It had no effect. No problems with suspect file versions for vBulletin files.

    Here's my PHP information, if that matters.

    System Linux XXXXXXXX 2.6.9-023stab046.2-enterprise #1 SMP Mon Dec 10 15:22:33 MSK 2007 i686
    Build Date Apr 12 2009 16:42:56
    Configure Command './configure' '--disable-mbregex' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-sockets' '--enable-zip' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mhash=/opt/mhash/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-png-dir=/usr' '--with-pspell' '--with-ttf' '--with-xmlrpc' '--with-xpm-dir=/usr/X11R6' '--with-zlib' '--with-zlib-dir=/usr' '--without-iconv' '--without-pear'
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /usr/local/lib
    Loaded Configuration File /usr/local/lib/php.ini
    PHP API 20041225
    PHP Extension 20060613
    Zend Extension 220060519
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    IPv6 Support enabled
    Registered PHP Streams zip, php, file, data, http, ftp, compress.bzip2, compress.zlib, https, ftps
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
    Registered Stream Filters string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, bzip2.*, zlib.*
    Last edited by cyburbia; Wed 6 May '09, 6:34am.
    Cyburbia Forums - a third place for urban planners
    http://www.cyburbia.org/forums

  • #2
    Try increasing the max_execution time of PHP to 60 seconds. This should allow all the PHP processing to take place on a post with a lot of BBCode or URL handling.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      Try increasing the max_execution time of PHP to 60 seconds. This should allow all the PHP processing to take place on a post with a lot of BBCode or URL handling.
      Tried changing php.ini. Doesn't help. Users are reporting errors for short posts that don't include any BBCode. Remember, I mentioned that in one post, I narrowed it down to the letter "o" in one location in the post that caused vB to 404.

      Tried disabling all of my plugins. Didn't help.

      Here's the entry from the domain log file whenever I try to edit a certain page that gives me a 404.

      [home ip] - - [06/May/2009:20:48:55 -0500] "POST /forums/editpost.php?do=updatepost&postid=undefined HTTP/1.1" 404 9018 "http://www.cyburbia.org/forums/showthread.php?t=36609" "Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3"
      [home ip] - - [06/May/2009:20:48:55 -0500] "POST /forums/editpost.php?do=updatepost&postid=474659 HTTP/1.1" 404 9019 "http://www.cyburbia.org/forums/showthread.php?t=36609" "Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3"


      Here's the log entry when I try posting that uneditable post in a different forum.

      [home ip] - - [06/May/2009:20:47:21 -0500] "POST /forums/newthread.php?do=postthread&f=29 HTTP/1.1" 404 9006 "http://www.cyburbia.org/forums/newthread.php?do=newthread&f=29" "Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3"

      Here's a regular post that did go through.

      [home ip] - - [06/May/2009:20:56:41 -0500] "POST /forums/newreply.php?do=postreply&t=37394 HTTP/1.1" 302 - "http://www.cyburbia.org/forums/newreply.php?do=newreply&noquote=1&p=490280" "Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3"[FONT="Courier New"]
      Last edited by cyburbia; Wed 6 May '09, 5:58pm.
      Cyburbia Forums - a third place for urban planners
      http://www.cyburbia.org/forums

      Comment


      • #4
        I tried uninstalling vbDrupal, thinking it might have had something to do with it. Nope. Here's the error I now get when trying to edit that one post at http://www.cyburbia.org/forums/showthread.php?t=36609.

        Internal Server Error

        The server encountered an internal error or misconfiguration and was unable to complete your request.

        Please contact the server administrator, (webmaster email) and inform them of the time the error occurred, and anything you might have done that may have caused the error.

        More information about this error may be available in the server error log.

        Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
        Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.6 Server at www.cyburbia.org Port 80
        ... and the log entry.

        (my home ip) - - [06/May/2009:22:18:18 -0500] "POST /forums/editpost.php?do=updatepost&p=474659 HTTP/1.1" 404 - "http://www.cyburbia.org/forums/editpost.php?do=editpost&p=474659" "Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3"
        Tried re-uploading all the vBulletin files. Nope. Didn't do a thing.

        The problem is in vBulletin. I think.
        Last edited by cyburbia; Wed 6 May '09, 8:15pm.
        Cyburbia Forums - a third place for urban planners
        http://www.cyburbia.org/forums

        Comment


        • #5
          Tried recompiling Apache, following the instructions here. That didn't help.

          This is frustrating, because it seems like my site is the only one that is experiencing the problem, and that there's no solution.
          Cyburbia Forums - a third place for urban planners
          http://www.cyburbia.org/forums

          Comment

          Related Topics

          Collapse

          Working...
          X