Announcement

Collapse
No announcement yet.

Search not really working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search not really working

    Hey

    I have a topic called "Aliens are my brother".

    But when I search for "aliens" (navbar or advanced search < even 'titles only') I get 0 results!

    I found more examples and no explanation.

    :/

  • #2
    Which search type are you using? Is that forum set to index posts?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      any search

      sometimes the search is useful, but overall seems really week NOW (i had the forum for 3 years). for a while it worked perfectly.

      Comment


      • #4
        Which search type are you using - Fulltext or the default vB search?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          vBulletin has types of search engines. A built-in index and MySQL's fulltext. What Steve is asking is which Search Type are you using? You can see this in your Admin CP under vBulletin Options -> Search Type.

          Most likely cause though for posts/threads that don't show up in the search results is that they are in forums that are set to be ignored by search indexing. You can check this in the Forum Manager by editing the forum in question and checking its options.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Your forum is currently using the vBulletin search engine. < Empty postindex and word tables? If yes, only when the forum is closed? Or what should I do to improve search results?

            All non private sections have new posts indexed in forum manager.

            Comment


            • #7
              First, make sue this is set to 'Yes' for all forums:

              Admin CP -> Forums & Moderators -> Forum Manager -> Edit Forum -> Index New Posts in Search Engine -> Yes

              Then rebuild the search index:

              Admin CP -> Maintenance -> Update Counters -> Rebuild Search Index

              If you still have this problem after that then a modification you installed is causing this.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                thx so much, solved

                Comment


                • #9
                  Glad to hear it.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X