Announcement

Collapse
No announcement yet.

cron.php weird behaviour?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cron.php weird behaviour?

    when forum is turned off, cron.php does not work as expected. instead of empty 1x1 gif image it prints default page stating that forum is turned off. this results in scheduled tasks not being run and prevents them from being fully tested before deploying. is this a bug or expected behaviour? if it's expected i think it should be documented somewhere, i couldn't find any mention of this.

    p.s. i spent two hours trying to find why scheduled tasks don't work.

  • #2
    Confirmed. Bug posted:

    http://www.vbulletin.com/forum/proje...?issueid=27629

    But this might not be considered a bug. Normally a test environment would be in a protected directory so that no one can access it. Then you don't need to turn off the forum.

    Comment


    • #3
      Jake,

      i may have a somewhat unique situation here since i'm now in final stages of testing my new forum before deploying it. i'm migrating from phpbb and naturally i want to be sure everything's working before making vbulletin available to the public, so you can imagine my frustration when i found that scheduled tasks are not working as expected just a couple of hours before launch.

      however i see the point in disallowing scheduled tasks from updating database while forum is turned off but i think it should be documented if it is an expected behaviour. also i don't think cron.php should print out "forum disabled" page instead of an image, if i were a web browser and got an html page instead of advertised gif image i would be very surprised at the very least. not running tasks and still printing out that image would suffice i think.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X