Announcement

Collapse
No announcement yet.

Image Upload Failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Image Upload Failure

    I'm still having image upload failures and my Server Admin has done EVERYTHING possible on the server end to fix this and he swears it is a vBulletin problem. It's been two months now of trying to fix this mess and the suggestions you had given with regards to pointing to this link do nothing to help fix this problem. Attached is a picture of what I am getting on my end.
    Here is what my server Admin has told me, he has a very reputable business with 63 servers for the last 12 years and hosts many forum site none of which have this problem. It is not a server issue, please help ASAP.
    This is what he said:
    The maintenance diagnostic in the admin area shows zero errors and that all existing attachments are working fine. We have other sites using attachment functionality (in fact hundreds of them) on the same server running fine. All we get is "Upload of file failed. " on the forum side of things.


    EDIT:
    I just tried to upload the picture to your site show you guys and it states upload of file failed, it is even happening on your site but it was an image size issue.
    I have adjusted my Attachment settings on my site for all types to 10MB and 1000x1000 pixels from 1MB 800x600 pixels and I am still having an issue with tiny files that are 10kb big and are 100x100 pixels.

    Where else do I have to go to edit these settings?
    Last edited by old7888; Fri 1 May '09, 6:01am.

  • #2
    You can't upload to here, either? That's not a vBulletin issue, but rather something that's going on with your PC. Disable your firewall and AV software and attempt to upload again.
    I drank WHAT?! - Socrates

    Comment


    • #3
      Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

      Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by Biker View Post
        You can't upload to here, either? That's not a vBulletin issue, but rather something that's going on with your PC. Disable your firewall and AV software and attempt to upload again.
        No I was able to after I adjusted the image size, that is not the case with my site. The problem lies within the VB code as my web host has stated. It's not in the PHP or mySQL software.

        Originally posted by Steve Machol View Post
        Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
        Here is a URL to my forums:

        www.78-88olds.com/forum


        You must be a member with at least 5 posts to view attachments and upload attchements. I can PM you a user name for you to work with if you like.

        Comment


        • #5
          The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

          You will also need to restart Apache after making this change.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            My server Admin looked into your suggestion and states this:

            Something is wrong with their script, as I've stated previously. There are hundreds of other scripts using the tmp directory properly and have been for years. The /tmp/ folder has the proper permissions.

            Also, their backend diagnostic tool works without error. They're not taking any time to give a real response to the question.


            Do you have any other suggestions?
            It was working fine for almost a year until about two weeks after I upgraded to 3.8.1 and now I am using 3.8.2.
            The versions of mysql and PHP are the latest and exceed the requirements.

            Comment


            • #7
              If that's the case then there is no reason your host can't set the 'upload_tmp_dir' to '/tmp'. The only reason would be ignorance, laziness or stubbornness.

              Regardless, this is a server issue not a vB one. Good luck.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                D. All of the above?
                I drank WHAT?! - Socrates

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X