Announcement

Collapse
No announcement yet.

problem on second step of install..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • toucan2442
    replied
    fatcow.com and what do you mean "what" control panel? yes i have one i didnt know it was a certain version. Sorry i would have bought the professional install its just I'm very broke and this forum was bought off of donations from members

    Leave a comment:


  • Wayne Luke
    replied
    Who is your hosting provider and what control panel do they give you to use?

    Leave a comment:


  • Steve Machol
    replied
    You are going to have to get help from your host for this. We have no way of knowing what your db info should be.

    Did you create a db and db user? Here is our online documentation for creating a new database and db user:

    http://www.vbulletin.com/docs/html/create_database

    And from the MySQL site:

    http://dev.mysql.com/doc/mysql/en/CREATE_DATABASE.html

    Leave a comment:


  • toucan2442
    replied
    i was told what my database was and still its a no go its killing me

    Leave a comment:


  • Steve Machol
    replied
    We have no way of knowing what your correct db info is. Have you tried contacting your host?

    The most likely cause of this error is that the info in your config.php file is wrong or your db user does not have full permissions to this database. Please read this for all the known causes of this error:

    http://www.vbulletin.com/forum/showthread.php?t=194542

    Leave a comment:


  • toucan2442
    replied
    i seem to have all of that correct, anyone care to take a look? you have a PM

    Leave a comment:


  • Wayne Luke
    replied
    The information in your config.php is incorrect. Here is an example of how to fill out the "includes/config.php" file. Let's start by assuming the following MySQL info (provided by your host):

    host - localhost
    user - testuser
    pass - testpass
    db name - testdb

    And here is what the top of the "includes/config.php" file would look like with this information entered:

    // ****** DATABASE NAME ******
    // This is the name of the database where your vBulletin will be located.
    // This must be created by your webhost.
    $config['Database']['dbname'] = 'testdb';

    // ****** TABLE PREFIX ******
    // Prefix that your vBulletin tables have in the database.
    $config['Database']['tableprefix'] = '';

    // ****** TECHNICAL EMAIL ADDRESS ******
    // If any database errors occur, they will be emailed to the address specified here.
    // Leave this blank to not send any emails when there is a database error.
    $config['Database']['technicalemail'] = '';

    // ****** FORCE EMPTY SQL MODE ******
    // New versions of MySQL (4.1+) have introduced some behaviors that are
    // incompatible with vBulletin. Setting this value to "true" disables those
    // behaviors. You only need to modify this value if vBulletin recommends it.
    $config['Database']['force_sql_mode'] = false;



    // ****** MASTER DATABASE SERVER NAME AND PORT ******
    // This is the hostname or IP address and port of the database server.
    // If you are unsure of what to put here, leave the default values.
    $config['MasterServer']['servername'] = 'localhost';
    $config['MasterServer']['port'] = 3306;

    // ****** MASTER DATABASE USERNAME & PASSWORD ******
    // This is the username and password you use to access MySQL.
    // These must be obtained through your webhost.
    $config['MasterServer']['username'] = 'testuser';
    $config['MasterServer']['password'] = 'testpass';

    Leave a comment:


  • toucan2442
    started a topic problem on second step of install..

    problem on second step of install..

    sorry guys im new and you guys are alot smarter than me!
    this is what im getting..

    attempting to attach to databaseError description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) /hermes/web01/b1718/moo.toucan2442/forums/includes/class_core.php on line 311
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X