Announcement

Collapse
No announcement yet.

'rebuild threads' hangs when run

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • glennybee
    replied
    A plugin is causing the problem, I just need to find which one.

    Thanks for your help, once again, Steve!

    Leave a comment:


  • Steve Machol
    replied
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);


    Do you have the same problem?

    Leave a comment:


  • glennybee
    replied
    I have tried the same function on another server and the same issue happens. So it looks like it's a database problem.

    I ran rebuild post cache and it took about 10 mins to complete, the rebuild thread info takes about 2 mins to hit the failing thread so it's not a timeout or memory problem, I don't think.

    Any other ideas please?

    EDIT:

    I've just found out that 'rebuild similar threads' also fails at the same point.
    Last edited by glennybee; Tue 21 Apr '09, 2:08pm.

    Leave a comment:


  • Steve Machol
    replied
    Try repairing the db then do this again with smaller batches. It's got to be either bad data or a server problem.

    Leave a comment:


  • glennybee
    replied
    Thanks Steve, that didn't cure it though!

    Leave a comment:


  • Steve Machol
    replied
    This may be a server time and/or memory limit. To increase your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', -1);
    ini_set("max_execution_time", "2880");

    Leave a comment:


  • glennybee
    started a topic 'rebuild threads' hangs when run

    'rebuild threads' hangs when run

    Hi folks,

    When I ran 'rebuild threads' it gots to thread 10650 and hung up. I deleted thread 10650 and now it hangs at 10649. Then I deleted thread 10649 and it hangs at thread 10648. So then I deleted thread 10651 but it still hangs at thread 10648. All threads were physically deleted.

    Any ideas please? There are about 170,000+ threads.

    Thanks!
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X