Announcement

Collapse
No announcement yet.

Cookie problems?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cookie problems?

    Our forum( http://www.aquariofilabcn.org/forum/ ) is having lots of problems since about 1 week ago:

    1.- When you enter in a thread, the posts shown are not all the posts, and you can’t answer to the thread.If you refresh the page with your web browser then the information shown is correct, but it happens every time you enter a thread or the forum index (you have to refresh continuously).

    2. - When you try to logout, the board returns a message: “All cookies have been deleted”, but if you enter to a thread you are still logged in.

    3. - The time of the posts sometimes is incorrect and your last visit is incorrect too.

    4. - The time shown on the footer is gmt+1 but the text says that is gmt+2.


    We are on a non-dedicated server and we have done a script to check the time of the server and it is correct. We were running vbulletin 3.7.4 when we detected the problem, now we have updated to 3.8.2 but we are still having the problem. I have tried to stop all the products we have installed and we have the same problems. It’s a cookie problem? What we can do?

  • #2
    1. To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?

    2. The server time was off while these posts were being made. Unfortunately there is no easy way to fix this. Of course, you need to fix the server time first. Then you would need to go into phpMyAdmin and modify the dateline column in the affected post and thread tables and enter the unixtimestamp that you want. You can use this online tool to convert dates and times to Unix Timestamps:

    http://www.onlineconversion.com/unix_time.htm

    Just remember to enter in the GMT values for the date and not the date and time in your specific timezone.

    3. vBulletin gets its time from the server. You need to set the timezone in the Admin CP to whatever you want the default to be and the DST settings should match whatever settings are on the server.

    Then each user needs to set their local timezones/DST in the User CP. If you do this correctly and the server time is correct, then the correct times will show.

    This also assumes that you have not modified the footer template to affect the DST detection code in it.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Point 3 solved.

      I try what you tell me about point 1, but what about point 2?:

      2. - When you try to logout, the board returns a message: “All cookies have been deleted”, but if you enter to a thread you are still logged in.

      are point 1 and 2 related?

      Comment


      • #4
        That is from a corrupted cookie, which unfortunately happens too frequently with IE in particular. They will need to manually delete any cookies for your site.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          IF you find yourself in a cookie/cache loop and you are using IE try this.

          Tools > Internet Options > delete cookies > yes > ok > close box down > close browser down completely like when you go away from your computer > double click on IE and go to your forum and login
          Aussiefootyforums

          New Site New forum
          Come and talk sports all day long


          Comment


          • #6
            I have manually deleted all the cookies (i'm running firefox) and I still have the same problem, if I log out and then I visit a thread that I visited when I was logged I appear as logged.

            Comment


            • #7
              I have done evberything and I still have the same problems.

              Comment


              • #8
                This is still a problem on the user end. There is nothing we can do in vB to fix this. Sorry.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  All users have the same problems I described here and in the ticket, then I think this is not a problem on the user end.

                  Comment


                  • #10
                    Then it has to be from a modification you made. There really are no other options. And you claimed to have followed my instructions which would have removed those modifications.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      P.S. Also I personally could not duplicate this problem in your support ticket which is further evidence that this is on the user end.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X