Announcement

Collapse
No announcement yet.

Problem with conditionals

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lynne
    replied
    Look at the page/template you are adding to and see what variables they are using there. That should give you a clue on what to use.

    Leave a comment:


  • Zachery
    replied
    Trial and error is usually the best method, you can also use $GLOBALS[forumid] That should work regardless.

    Leave a comment:


  • tommeyboy
    replied
    In the future, how can I determine what the conditional should look like? Is there a place I can find out which conditional to use and the syntax, that will help me to narrow down the choices in the future?

    Leave a comment:


  • Lynne
    replied
    Originally posted by tommeyboy View Post
    When I looked at the conditionals FAQ, I thought there was only one set of conditionals. The templates I'm trying to use the conditionals in are postbit and postbit legacy.
    The FAQ gives examples. It couldn't possibly list every conditional for every page.

    Leave a comment:


  • tommeyboy
    replied
    When I looked at the conditionals FAQ, I thought there was only one set of conditionals. The templates I'm trying to use the conditionals in are postbit and postbit legacy.



    Originally posted by Lynne View Post
    The variable used depends on what template you are putting that condition in. It could be that you need to replace $forumid with $foruminfo['forumid'] or $forum['forumid'] or $threadinfo['forumid'] or $thread['forumid'] or something else. You didn't say what template so try each of those.

    Leave a comment:


  • Lynne
    replied
    The variable used depends on what template you are putting that condition in. It could be that you need to replace $forumid with $foruminfo['forumid'] or $forum['forumid'] or $threadinfo['forumid'] or $thread['forumid'] or something else. You didn't say what template so try each of those.

    Leave a comment:


  • tommeyboy
    started a topic Problem with conditionals

    Problem with conditionals

    I have a forum where I want to limit google ads and don't want them to show up on several of my forums. I've been trying to get the conditionals to work, but I haven't had much success.

    My conditional is as follows:
    Code:
    <if condition="!in_array($forumid, array(44,45,46,47,48,49,51,52))">
    Google Adsense code here
    </if>
    The forum id's that I want to exclude are 44,45,46,47,48,49,51,52. Anyone know what's wrong?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X