Announcement

Collapse
No announcement yet.

Database Errors - please help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Errors - please help

    Yesterday was the worse. It crashed for more then an hour. Today I've received enough to aggravate me. These are the errors I am getting:

    Database error in vBulletin :

    mysql_connect() [function.mysql-connect]: User brettxw8 already has more than 'max_user_connections' active connections
    /hermes/bosweb/web198/b1985/sl.brettxw/public_html/forums/forums/includes/class_core.php on line 311

    MySQL Error :
    Error Number :
    Request Date : Friday, March 20th 2009 @ 12:15:17 PM
    Error Date : Friday, March 20th 2009 @ 12:15:17 PM
    Script : http://forums.blackberryos.com/forum...ad.php\?p=2982
    Referrer : http://forums.blackberryos.com/forum...ad.php\?p=2982
    IP Address : 194.8.75.145
    Username :
    Classname : vb_database
    MySQL Version :

    ---------------------------

    Database error in vBulletin :

    mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on 'brettxw.startlogicmysql.com' (111)
    /hermes/bosweb/web198/b1985/sl.brettxw/public_html/forums/forums/includes/class_core.php on line 311

    MySQL Error :
    Error Number :
    Request Date : Friday, March 20th 2009 @ 10:53:28 AM
    Error Date : Friday, March 20th 2009 @ 10:53:28 AM
    Script : http://forums.blackberryos.com/forum...ead.php\?t=147
    Referrer : http://forums.crackberry.com/f132/ne...-great-181926/
    IP Address : 64.72.85.122
    Username :
    Classname : vb_database
    MySQL Version :

    ------------------------------------

    Any ideas how to stop or limit them??

    Thank you in advance.

  • #2
    1: Max User Connections is a limitation placed on the MySQL user when it is created. You can remove this by logging in as the root user for the MySQL server. If you are on a shared server then you will need to contact your hosting provider to have the limit revised.

    2: Assuming the database info in your vBulletin config.php file is correct, this is a server issue. Please see this page for the causes of this error:

    http://www.vbulletin.com/docs/html/cantconnect

    Comment


    • #3
      Originally posted by Carrie Anderson View Post
      1: Max User Connections is a limitation placed on the MySQL user when it is created. You can remove this by logging in as the root user for the MySQL server. If you are on a shared server then you will need to contact your hosting provider to have the limit revised.

      2: Assuming the database info in your vBulletin config.php file is correct, this is a server issue. Please see this page for the causes of this error:

      http://www.vbulletin.com/docs/html/cantconnect

      thank you so much Carrie!!

      Comment


      • #4
        So I talked with the help at my host.. this is what she said:

        The maximum number of database queries per user is 50,000/hr.
        Petra Knight: The queries will reset every hour and is kept by user. However, every time the pages on your Web site are accessed you are still attempting to make queries to the database server. Because of this, even though you are getting errors your script is still accumulating the queries.
        Petra Knight: Query limit is the maximum number of database actions performed in one hour by a specific user. Note that a user can have multiple concurrent MySQL connections, in which case the sum of all database actions for all connections cannot exceed the given limit.

        i dont think that is right?

        Comment


        • #5
          That is not a queries error, it's a max_user_connections error. This is a problem with your host. They are purposely limiting your MySQL connections and your forums are too busy to operate under this restriction.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Hey steve. thanks for your help. I told them exactly what you typed and this was their response this time:

            Suzie Norris: It appears that the database has exeeded the maximum querry limit prescribed on our server.
            Suzie Norris: The maximum number of concurrent MySQL connections per user is 10 and the maximum number of database queries per user is 50,000/hr. You can refer the link: http://www.startlogic.com/knowledgebase/read_article.bml?kbid=2539 to get more information on this limit.
            Suzie Norris: Query limit is the maximum number of database actions performed in one hour by a specific user.
            Suzie Norris: Note that a user can have multiple concurrent MySQL connections, in which case the sum of all database actions for all connections cannot exceed the given limit.
            Suzie Norris: When you exceed the maximum query limit, your Web site will be taken offline. However, it will be reset by the end of the hour and the Web site will be activated.



            What hosting company would you recommend?

            Comment


            • #7
              Your forums are simply too busy for the very restricted hosting account you are on. Those restrictions are unreasonable for a quality host. Unfortunately your only choices are to live with these restrictions and risk having your site shutdown with no warning, or finding a more suitable host.

              We do not make official recommendations regarding hosting companies. I suggest you view the vBulletin Hosting Options forum for advice from our customers:

              http://www.vbulletin.com/forum/forum...?s=&forumid=11

              Also checkout this site:

              http://www.webhostingtalk.com/
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X