Announcement

Collapse
No announcement yet.

images and ie8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    not got ie8 on any more so cannot answer your first question Lynne - but its not a style problem - have done all the make a new style things - imo its not an addon - have disabled them - deleted them - uninstalled them and re-installed them - nothing helps

    but as i have said elsewhere - maybe in this thread or another that is running

    install a new copy of the board - add all the styles - add all the addons - add some images and images then work for me

    then again if jake or others from here look at my main board images work for them

    i have given up - just told my members to stick with ie7 or any other browser than ie8 - end of problem until somebody here or at M$ issues a fix
    Last edited by tony adams; Sat 28 Mar '09, 11:13am.

    Comment


    • #32
      I just spent some time looking closer at the issue and found nothing.

      I removed any add-ons I don't use anymore, I loaded vB 3.8.2, and I created a new Style not using any of my customizations. Still no images show in IE 8.

      Comment


      • #33
        Thats kinda strange. I had massive problems, also on my testsit. Removed my silly add-ons, including removing all files using the suspicious files tool. Then uploaded 3.8.2 and it worked fine. Won´t do it on my active forum. Will wait for v.4.

        Comment


        • #34
          Originally posted by Mannen View Post
          Thats kinda strange. I had massive problems, also on my testsit. Removed my silly add-ons, including removing all files using the suspicious files tool. Then uploaded 3.8.2 and it worked fine. Won´t do it on my active forum. Will wait for v.4.
          as add-ons did you have any of the following...

          vB Ad Management 3.13 Forum-wide advertisement management

          vBClassified 1.3.2 The ultimate vBulletin classifieds system.

          vBClassified Forum Integration 3.7.x 1.2 Forum Integration for vBulletin 3.7.x

          vBulletin Blog 1.0.5 Personal web log, integrated with vBulletin.

          Comment


          • #35
            I did not. I had:

            - CYB casino
            - PM enhancer
            - Chatbox
            - Yet another reward system

            Was about it. No clue what was the problem really, and it didnt work until i uploaded the new files.

            Comment


            • #36
              a solution for my board

              but first full credit to one of my members [john] who pointed me in a direction that gave me the answer

              most of our images are jpg by default and jpg if the board software compresses them - it was johns idea to try other formats - gifs. jpeg's etc - these he found to display perfectly in ie8

              so a look at the settings

              i found this

              Content-type: unknown/unknown
              in - Attachment type/jpg/mime type and headers

              i can say with certainty i have not set that - did ie8 - i have no idea

              alter it to

              Content-type: image/jpeg
              which i think is default and jpg's show - as do all other images

              Comment


              • #37
                Bravo! That is the fix! Thank you so much, not sure why vB couldn’t find this, but glad you did.

                I’m curious why this only impacted some forums? Why were our jpg “Content-type: unknown/unknown”? Older forums that maybe had to manually add jpg as attachment type way back when?

                Comment


                • #38
                  The default mime type for jpg has been this ever since I can remember: Content-type: image/jpeg

                  Honestly it would never have occurred to me that someone would have changed this from the defaults.

                  Nice work finding this out though.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #39
                    Originally posted by Steve Machol View Post
                    The default mime type for jpg has been this ever since I can remember: Content-type: image/jpeg

                    Honestly it would never have occurred to me that someone would have changed this from the defaults.

                    Nice work finding this out though.
                    I have never ever changed this on my vB, I'm not that smart. I don't remember which version I started with vB, but around 2003. Would any of the mods change this? If so, it would have had been last couple years with the automated plugin type system. Before that none of the mods I did changed the attachment setting for jpg.

                    Comment


                    • #40
                      I started in 2001. It's been set to that since then.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #41
                        i am with rob on this - i certainly have not changed it - but cannot argue something - not someone - has

                        my board was a clean install of 3.8 when it came out- i had been running 3.5 and decided to start again rather than go the upgrade path - mods and styles were then added

                        sometime along the way ie8 beta was added and then ie8 - something changed the setting

                        HOWEVER - a test board that was installed a couple of weeks ago with all the styles ported over and the same mods added works fine - it was from that board that i found the correct setting for the original board

                        i cannot figure it - maybe someone else will

                        Comment


                        • #42
                          Originally posted by tony adams View Post
                          a solution for my board

                          but first full credit to one of my members [john] who pointed me in a direction that gave me the answer

                          most of our images are jpg by default and jpg if the board software compresses them - it was johns idea to try other formats - gifs. jpeg's etc - these he found to display perfectly in ie8

                          so a look at the settings

                          i found this



                          in - Attachment type/jpg/mime type and headers

                          i can say with certainty i have not set that - did ie8 - i have no idea

                          alter it to



                          which i think is default and jpg's show - as do all other images

                          It helps. I write:
                          Code:
                          Attachment type/jpg/mime type and headers
                          And when I click on the image gives a code, rather than a picture.

                          Comment


                          • #43
                            Code:
                            Content-type: image/jpeg
                            It works, too.

                            Comment


                            • #44
                              It works when you configure: Content-type: image/jpeg
                              The problem was that that did not delete old files browser.
                              THANK YOU!

                              Comment


                              • #45
                                Originally posted by FanaT View Post
                                It works when you configure: Content-type: image/jpeg
                                The problem was that that did not delete old files browser.
                                THANK YOU!
                                Hi FanaT,

                                What do you mean by: "The problem was that that did not delete old files browser"?

                                We use VB4.0.3. and Content-type: image/jpeg is in VB default setting but veiwers use IE8 are still having the problem viewing jpeg image.
                                Last edited by Fountainhead; Mon 10 May '10, 10:20am.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X