Announcement

Collapse
No announcement yet.

Parse Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Parse Error

    I installed a plugin and got this error:

    Parse error: syntax error, unexpected T_LNUMBER in /home/fishingn/public_html/forum4/global.php(607) : eval()'d code on line 4

    I immediately removed the plugin and associated files and still got the error. I ended up deleting all files and re-installing fresh files and still have the error.

    I ran upgrade.php as recommended in another thread but I am still getting the error. Can anyone help please?

  • #2
    As per the other thread this error is from a plugin you've installed. You canot get that error with the default vB files, templates and no add-ons.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve, thank you for your reply. I re-uploaded all the original files but now it wont let me log into the admin, I get this error:

      Unable to add cookies, header already sent.
      File: /home/fishingn/public_html/forum4/global.php(607) : eval()'d code
      Line: 4

      Do you have any suggestions?

      Comment


      • #4
        That is still from an add-on. Follow all those instructions, including disabling add-ons.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I cannot follow through with the instructions because I cant login to the admin panel.

          Comment


          • #6
            These instructions do not involve logging into the ACP:

            Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

            define('DISABLE_HOOKS', true);
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              OK, I have disabled all plugins via editing the config file and the error goes away. However I NEED to run the vbadvanced cmps plugin as it is an integral part of my site. How can I get the plugin system working again without the error coming up? I have had the vBAdvanced plugin running for years without problem so I know it is not the fault. The problem came when I installed an ad network plugin today, which I have completely removed.

              Comment


              • #8
                You will need to contact vBAdvanced for help with his.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  tried contacting vbadvanced and the creator of the bogus plugin to no avail.

                  Anyway, I did do some playing around and believe I narrowed it down to a database problem, not a file problem. I edited the config file to pull up an older backup of the DB and the problem went away.

                  However, this backup is over a month old and I would still like to retain my recent info., so I am now going through a copy of each DB and looking for indifferences that may have caused the problem.

                  I will post my results when I find the problem. If I dont find it then at worst I only lost a months worth of threads. If anybody else has some input on where to look, please reply. Thank you.

                  Comment


                  • #10
                    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                    Next, disable all plugins.

                    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                    define('DISABLE_HOOKS', true);


                    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                    Do you have the same problem?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Heres what I did:

                      1. Completely erased all files and uploaded a fresh copy of 3.8.1

                      2. tried to run "Suspect File Versions" but could not log into the admin. Got error -
                      Unable to add cookies, header already sent.
                      File: /home/fishingn/public_html/forum5/global.php(607) : eval()'d code
                      Line: 3


                      3. Edited config file "define('DISABLE_HOOKS', true);"

                      4. Errors go away! AdminCP login successful!

                      5. Ran "Suspect File Versions. Results show all original files. (should be, since I completely erased everything in step 1)

                      6. Created new style and viewed forum with new style - no errors.

                      7. Removed "define('DISABLE_HOOKS', true);" from config file. Error returns, even under new style. Error logging into adminCP also returns.

                      I believe the problem to be somewhere in the database, especially since I have completely erased all files and started with new. I can edit the config file to point to an older DB copy and everything works fine.

                      Comment


                      • #12
                        That is solid proof that the problem is with one of your plugins.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          I have no doubt it was the result of a plugin I installed yesterday that was given to me by an advertising agency that wanted to put ads on my site.

                          I have completely deleted the plugin and all files it came with, but somehow it wrote something to the database (I'm guessing in templates) that is causing the error. I just wish I knew where to look so I can take out whatever it wrote. That is a huge DB!

                          Comment


                          • #14
                            The fact that it fgoes away with define('DISABLE_HOOKS', true); means that you have not completely removed the plugin that is causing this. That includes removing all it's files and changes to the database and templates. You need to post over at www.vbulletin.org for specific help removing this.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X