Announcement

Collapse
No announcement yet.

Browser Icons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Browser Icons

    Attached is an image of my browser.

    See the images that appear on the browser?

    There's one with a Yahoo icon, there are three with VB icons, two with a blue "K", one that's green that says "UD" on it...

    I want my site to have an icon other than the default one that currently comes up. How do I do this?

    What are these called? Browser icons? URL Icons?
    Attached Files

  • #2
    That is the favicon.ico file in your forum directory. Just replace that image. Note that browsers love to cache those images, so you might not see the new image in your browser if you have already bookmarked it.

    favicon.ico files are supposed to be 16 x 16 or 32 x 32 pixels, 16 colors or 256 colors, gif or bmp format with an "ico" extension instead of "gif" or "bmp". The most compatible format is said to be 16 x 16, 16 colors.

    Sometimes you also have to edit this template:

    Admin CP -> Styles & Templates -> Style Manager -> Common Templates (in the menu) -> headinclude

    Add this to the very bottom:

    Code:
    <LINK REL="SHORTCUT ICON" HREF="http://www.vbulletin.com/forum/favicon.ico">
    Change the URL appropriately. That should get the favicon image working for you.

    Comment


    • #3
      Not only did you answer what I asked, but you answered what I would ask next, and after that and after that.

      That's a very awesome response, Jake. Very complete and helpful. You rock!

      Thank you.

      Comment


      • #4
        Okay, I finally got the right type of file and I replaced the old file. Then I tried it and it didn't work, so I added the part you told me to add to the bottom of the headinclude section of the style manager (common templates).

        It's still not working.

        Any advice?

        Comment


        • #5
          What's the URL and what is the image you are supposed to see? I have founfd that some browser such as IE rarely get favicons right.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol View Post
            What's the URL and what is the image you are supposed to see? I have founfd that some browser such as IE rarely get favicons right.
            The URL is http://www.gametramp.com/forums/index.php

            I can't get it to function in FF either. I think I'm the problem this time. I suspect it has something to do with the file itself. I had someone else make it (I'm not capable of making an .ico file) and they uploaded it. I downloaded it and saved it to my hard drive but my computer didn't recognize what kind of file it was. I then uploaded it to the server over the old favicon.ico file.

            Maybe something got lost in the translation since my computer didn't even know what this file was.

            Comment


            • #7
              PS: The image I am using (which I downloaded and then transferred onto my boards to overwrite the old file with is this one:


              http://airstrike1337.googlepages.com/goon.ico

              Comment


              • #8
                Originally posted by Alastor View Post
                The URL is http://www.gametramp.com/forums/index.php

                I can't get it to function in FF either. I think I'm the problem this time. I suspect it has something to do with the file itself. I had someone else make it (I'm not capable of making an .ico file) and they uploaded it. I downloaded it and saved it to my hard drive but my computer didn't recognize what kind of file it was. I then uploaded it to the server over the old favicon.ico file.

                Maybe something got lost in the translation since my computer didn't even know what this file was.
                Anyone can make an ico file. There are free online tools.
                Here's one: http://tools.dynamicdrive.com/favicon/.
                Save it as favicon.ico in your forum directory.
                Upload it and then clear your browser cache, i.e. hit Ctrl + F5.
                Cliff
                PathLabTalk
                Square Wheels Cycling

                Comment


                • #9
                  Thanks for the help, but I can't seem to make it work for some reason.

                  I've tried multiple times.

                  Comment


                  • #10
                    Originally posted by Alastor View Post
                    Thanks for the help, but I can't seem to make it work for some reason.

                    I've tried multiple times.
                    Did you upload the file as goon.ico? If yes, did you edit the template as Jake described?
                    Try editing the template or renaming it favicon.ico.
                    Cliff
                    PathLabTalk
                    Square Wheels Cycling

                    Comment


                    • #11
                      Originally posted by dilbert View Post
                      Did you upload the file as goon.ico? If yes, did you edit the template as Jake described?
                      Try editing the template or renaming it favicon.ico.
                      No. When I uploaded the file to the boards and the site, I renamed it to favicon.ico.

                      I did add the section that Jake told me to add anyway, just because...


                      Wait.

                      Wait wait. Crrrap... Let me try something...

                      Yeah, that got it.

                      Okay, to my credit at least I knew I was screwing something up.

                      I had cut and pasted Jake's code verbatim and hadn't changed what I needed to so it was drawing on my own forum directory appropriately.

                      My bad.




                      Okay, so now it's there and working and thank you all very much!

                      Now, I have a new question. If you click on my link you can see the favicon. The problem is the background color. I had this set to transparent when it was a .gif so it would match the browser default of whatever browser the customer was using.

                      That appears to have been turned gray somehow.

                      How can I set this background to be transparent so that only the color of the grenade is visible regardless of the style choices of my customers?

                      Comment


                      • #12
                        Originally posted by Alastor View Post
                        No. When I uploaded the file to the boards and the site, I renamed it to favicon.ico.

                        I did add the section that Jake told me to add anyway, just because...


                        Wait.

                        Wait wait. Crrrap... Let me try something...

                        Yeah, that got it.

                        Okay, to my credit at least I knew I was screwing something up.

                        I had cut and pasted Jake's code verbatim and hadn't changed what I needed to so it was drawing on my own forum directory appropriately.

                        My bad.




                        Okay, so now it's there and working and thank you all very much!

                        Now, I have a new question. If you click on my link you can see the favicon. The problem is the background color. I had this set to transparent when it was a .gif so it would match the browser default of whatever browser the customer was using.

                        That appears to have been turned gray somehow.

                        How can I set this background to be transparent so that only the color of the grenade is visible regardless of the style choices of my customers?
                        Glad you got it working, not sure why the bg is gray.
                        Maybe you can try again?
                        I have a very simply one for now on my site that is just three letter and they are on a transparent bg.
                        Cliff
                        PathLabTalk
                        Square Wheels Cycling

                        Comment


                        • #13
                          Originally posted by dilbert View Post
                          Glad you got it working, not sure why the bg is gray.
                          Maybe you can try again?
                          I have a very simply one for now on my site that is just three letter and they are on a transparent bg.
                          Wha thankee. I don't know why I lost the background either. I'll try again.

                          Thanks for the support and help!

                          Comment


                          • #14
                            I know for a fact that the background of this last try was set to transparent as a .gif but that when it converted it to an .ico file it changed the background color. Any advice?

                            Comment


                            • #15
                              Thanks for the link Dilbert. Been looking for a way to make one also.
                              ...

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X