Announcement

Collapse
No announcement yet.

Increasing attachment size

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Increasing attachment size

    So I tried uploading an attachment to a thread and the attachment manager said:

    Your file of 931.9 KB bytes exceeds the forum's limit of 97.7 KB for this filetype.
    How Can I make the attachment limit 1mb instead of 97.7Kb?

    Thanks guys


  • #2
    You can change the maximum size per extension here:

    Admin CP -> Attachments -> Attachment Manager -> Edit

    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks Steve, I'll give those a try

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X