Announcement

Collapse
No announcement yet.

Fatal error: Maximum execution time of 30 seconds exceeded

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mhme
    replied
    I have this problem too. That is because of an specific post on the thread. CPU Usage of Apache is 100% during loading of that post.(I have a dedicated server and there is only a medium forum on it. By default CPU Usage is under 1%)
    I couldn't find any solution to solve that. So I have deleted that post directly in database and everything is Ok now!
    It seams this is a bug in vB!

    Leave a comment:


  • Jinovich
    replied
    Originally posted by BozzaJos View Post
    Is this really the correct solution to the problem? I ask this because when I am inside the section where the topic is located and I click on another topic, it is loading instantly. But when I click on that specific topic, it keeps loading until it gives to error. Kinda weird don't you think?

    Is it a large thread?

    It has happened to me before but under a different error and circumstance, I didn't want to permanently change the parameter that I had it set as in PHP.ini.

    So what I did was set the value to a higher number until the error was resolved, then split the thread into two then reduced the parameter value to its original number.

    But it isn't weird that it only occurs for one thread as if the thread isn't fully executed within the given time parameter PHP will throw errors at you.

    Leave a comment:


  • BozzaJos
    replied
    Originally posted by Jinovich View Post
    If you have root access I would suggest increasing your max_execution_time from 30 to something like 180 in PHP.ini.

    If your on shared hosting then you will need to ask your webhost to do so.
    Is this really the correct solution to the problem? I ask this because when I am inside the section where the topic is located and I click on another topic, it is loading instantly. But when I click on that specific topic, it keeps loading until it gives to error. Kinda weird don't you think?

    Leave a comment:


  • Jinovich
    replied
    If you have root access I would suggest increasing your max_execution_time from 30 to something like 180 in PHP.ini.

    If your on shared hosting then you will need to ask your webhost to do so.

    Leave a comment:


  • Fatal error: Maximum execution time of 30 seconds exceeded

    Hello ladies and gentlemen,

    I recently upgraded to vBulletin 3.8 and everything seemed to be working. However, when I visit one specific topic, I get an error. Instead of explaining what the error is, click on the following link instead:

    http://www.fmformation.net/writers-s...-big-time.html

    If you don't want to, this is the error message:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/*****/domains/********/public_html/includes/functions.php(5721) : eval()'d code on line 150

    Could you please help me out what is causing this problem and how to fix it?
    Other topics are working fine but this one just isn't.

    Thank you kindly in advance.

    Regards,

    Bozza
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X