Announcement

Collapse
No announcement yet.

User cannot access User CP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Reynaldo
    New Member

  • Reynaldo
    replied
    Thank you Steve,

    I found the cause of the problem while searching for "pmfolders" (by the way, I have no idea why a search on this forum for "Unsopported Operand" rends no results).

    Recently I upgraded/converted my charset to UTF-8 to facilitate integration with Wordpress. It seems this user's custom private folders names got corrupted.

    Anyway, I read this thread:
    http://www.vbulletin.com/forum/showt...ight=pmfolders
    and then kinda did the same thing the OP did, I accessed the DB directly and renamed the private folders. It is working fine now, thank you for your help.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Fill out a support ticket at:

    http://members.vbulletin.com/members...ontactform.php

    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.

    Leave a comment:

  • Reynaldo
    New Member

  • Reynaldo
    replied
    Steve:

    Thank you!
    Part 10 did the trick of allowing me to see what was going on:
    10. Sometimes this can also be caused when PHP has the 'display_errors' function turned off. So instead of displaying the actual error so you can see what is wrong, you get a blank page. Look at your phpinfo page and if 'display_errors' is Off or '0', then add this line to your includes/config.php file right under <?php

    ini_set("display_errors", true);
    Anyway, here is the error:
    Fatal error: Unsupported operand types in /var/www/vhosts/mydomain.com/httpdocs/includes/functions_user.php on line 263
    While looking at the file, these are the lines mentioned in the error:
    PHP Code:
    261    if (!empty($vbulletin->userinfo['pmfolders']))
    262    {
    263        $pmfolders $pmfolders unserialize($vbulletin->userinfo['pmfolders']);
    264    
    I know it is related to the user's Private Messages. Any idea how to fix it without nuking it?

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    In that case please see this for all the known causes of blank or 'white' pages:

    http://www.vbulletin.com/docs/html/blank_pages

    Leave a comment:

  • Reynaldo
    New Member

  • Reynaldo
    replied
    Hello Steve:

    Thank you for your reply. It doesn't look like ModSecurity is the one to blame here, it doesnt look to be installed and only this user is being affected by this problem. Anyway, here is some info from phpinfo() confirming it is not loaded:

    Loaded Modules
    core prefork http_core mod_so mod_auth_basic mod_auth_digest mod_authn_file mod_authn_alias mod_authn_anon mod_authn_dbm mod_authn_default mod_authz_host mod_authz_user mod_authz_owner mod_authz_groupfile mod_authz_dbm mod_authz_default util_ldap mod_authnz_ldap mod_include mod_log_config mod_logio mod_env mod_ext_filter mod_mime_magic mod_expires mod_deflate mod_headers mod_usertrack mod_setenvif mod_mime mod_dav mod_status mod_autoindex mod_info mod_dav_fs mod_vhost_alias mod_negotiation mod_dir mod_actions mod_speling mod_userdir mod_alias mod_rewrite mod_proxy mod_proxy_balancer mod_proxy_ftp mod_proxy_http mod_proxy_connect mod_cache mod_suexec mod_disk_cache mod_file_cache mod_mem_cache mod_cgi mod_version mod_fcgid mod_perl mod_php5 mod_proxy_ajp mod_ssl
    Is there some way to increase the verbosity of vBulletin to make diagnosing this easier? I have no idea where it is breaking and it seems turning on Debug Mode is not working either as I still get an empty page.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    This may be due to mod_security. Please see this thread for the fix:

    http://www.vbulletin.com/go/modsecurity

    Leave a comment:

  • Reynaldo
    New Member

  • Reynaldo
    started a topic User cannot access User CP

    User cannot access User CP

    Hello:

    I got this user who for some unknown reason cannot access the User CP and or check Private Messages. I logged in to her account and I can confirm it is happening to me too, it is just an empty page with no error, no html code, no messages, nothing at all.

    The user is a moderator and I have tried the following:
    • Promoting her to Administrator.
    • Demoting her to normal user.
    • Disabling all plugins.
    • Enabling Debug mode in hope I would see some weird message.
    • Disabling Xcache

    Any ideas how I can troubleshoot or force vBulletin to spit out whatever is preventing/stopping its execution?

    Thanks in advance for your help.

Related Topics

Collapse

Working...
X