Announcement

Collapse
No announcement yet.

Attachments goto an error page when submitting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments goto an error page when submitting

    3.8.1 - Just upgraded to this as well as our server so I know this is just something easy. Goto upload an image and after clicking upload I get a standard IE error with no code (500,404, etc). There is no entry in error_log, diagnostics passes (but upload_tmp_dir was set to none?), safe mode off, php 5, gd2, and ImageMagick 6.2 installed. Tried both IM and GD to no avail. Happens for registered users and admin. The only thing left for me to possibly think is that we just moved servers and there are possibly a few propagation issues but I figure since I am on the site it should work. Any ideas? TIA.

    Update: Albums are updating just fine as well as avatars.
    Last edited by Kode; Fri 30 Jan '09, 8:58pm.
    joor.com | rcfiles.com
    VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
    Host: ThePlanet Dedicated Xeon 3210

  • #2
    What is a 'standard IE error'? What error do you see if you use a different browser?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Mozilla Firefox is just a blank white page with nothing in the source.

      This is the IE page

      Internet Explorer cannot display the webpage


      Most likely causes:
      • You are not connected to the Internet.
      • The website is encountering problems.
      • There might be a typing error in the address.
      What you can try:

      Diagnose Connection Problems

      More information
      joor.com | rcfiles.com
      VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
      Host: ThePlanet Dedicated Xeon 3210

      Comment


      • #4
        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Steve, appreciate the time you have helped on this. Unfortunately I did all the steps you mentioned. I went on to chmod the whole forums directory to 777 just to see if it was a permissions issue, turned off ajax completely because I wasn't sure if the script was using it, and switched back and forth between GD and ImageMagick. I am really at a lose trying to understand this.

          Update: To be safe, I just uploaded the whole 3.8.1 minus the install folder and even created a new config.php to cover everything.
          joor.com | rcfiles.com
          VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
          Host: ThePlanet Dedicated Xeon 3210

          Comment


          • #6
            What's the URL?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              The url is rcfiles.com but I got it worked out. Here were my steps. I upgraded from 3.1 to 3.8.1, then moved servers a few days later. I did move the files into the database and back to the filesystem before the move but it was a different file structure on the new server. So I moved attachments back into the DB and out again, noticed that the path was wrong by default to move out to the file sytem (problem 1 I am sure). And when rebuilding thumbnails I noticed the folder needed to be changed to 777. Everything works again. I am guessing that maybe I never changed that in the attachpath. Where is that located? /path/to/your/attachment/directory
              joor.com | rcfiles.com
              VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
              Host: ThePlanet Dedicated Xeon 3210

              Comment


              • #8
                You set her attachment path yourself here:

                Admin CP -> Attachments -> Attachment Storage Type
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X