Announcement

Collapse
No announcement yet.

FLV Player for external FLV source problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aachi
    replied
    Hello guys.. I have upgraded FLV player BB Code here for multiple Videos/ threads

    Do here...

    http://www.vbulletin.org/forum/showt...=177213&page=3

    Leave a comment:

  • tijmen_4real
    Member

  • tijmen_4real
    replied
    I got a problem similar to this, but i can't get the player to work at all:

    tag name: flv
    replacement: <script type="text/javascript" src="http://www.deorvanheemskerk.nl/journaal/embed/swfobject.js"></script>
    <div id="player">"Please refresh page for player"</div>
    <script type="text/javascript">
    var s1 = new SWFObject('http://www.deorvanheemskerk.nl/journaal/embed/player.swf','mpl','640','480','9');
    s1.addParam('allowscriptaccess','always');
    s1.addParam('allowfullscreen','true');
    s1.addParam('flashvars','&file={param}&frontcolor=#ffffff&screencolor=#000000&controlbar=o ver&backcolor=#003F86&logo=http://www.deorvanheemskerk.nl/journaal/logo2.png');
    s1.write('player');
    </script>
    example: [FLV]http://content.bitsontherun.com/videos/3ta6fhJQ.flv[/FLV]
    Please, can someone help me out on this ?

    Leave a comment:

  • DoDeH1
    Senior Member

  • DoDeH1
    replied
    Yeah, I did it.
    I replaced the id with {param} and everything is working now.
    I found that every player needs a different id so I replaced the id with {param} to put the instead of it the full path of the video.
    Hope to help others with this solve.

    Leave a comment:

  • DoDeH1
    Senior Member

  • DoDeH1
    replied
    Originally posted by Jake Bunce View Post
    Check the source code of both posts when viewing the showthread.php page. Make sure the appropriate HTML code is being inserted for both BB codes in both posts. If the code is in place and correct then perhaps there is a problem with the code itself that makes it not work twice on the page.
    Yes, you're right. I figured it that it's the problem of the code itself from the javascript. I'll have to ask those who wrote it.
    Thank you for the anserws.

    Leave a comment:

  • Jake Bunce
    Senior Member

  • Jake Bunce
    replied
    Check the source code of both posts when viewing the showthread.php page. Make sure the appropriate HTML code is being inserted for both BB codes in both posts. If the code is in place and correct then perhaps there is a problem with the code itself that makes it not work twice on the page.

    Leave a comment:

  • DoDeH1
    Senior Member

  • DoDeH1
    replied
    Originally posted by MrNase View Post
    Try this:

    Replace

    <script type="text/javascript" src="embed/swfobject.js"></script>

    with

    <script type="text/javascript" src="FULLURLTOTHEFILE/swfobject.js"></script>




    .
    Did it and still the same.
    here is the exact code I use
    Code:
    <script type="text/javascript" src="http://www.dfgrom.com/embed/swfobject.js"></script>
    <div id="player">"Please refresh page for player"</div> 
    <script type="text/javascript">
    var s1 = new SWFObject('http://www.dfgrom.com/embed/player.swf','mpl','352','201','9');
    s1.addParam('allowscriptaccess','always');
    s1.addParam('allowfullscreen','true');
    s1.addParam('flashvars','&file={param}&frontcolor=#ffffff&screencolor=#000000&controlbar=over&backcolor=#003F86&logo=http://www.dfgrom.com/forums/logo2.png');
    s1.write('player');
    </script>

    Leave a comment:

  • MrNase
    Senior Member

  • MrNase
    replied
    Try this:

    Replace

    <script type="text/javascript" src="embed/swfobject.js"></script>

    with

    <script type="text/javascript" src="FULLURLTOTHEFILE/swfobject.js"></script>




    .

    Leave a comment:

  • DoDeH1
    Senior Member

  • DoDeH1
    replied
    Hi,
    I pm U an account so U can see how it looks.
    cheers!

    Leave a comment:

  • Jake Bunce
    Senior Member

  • Jake Bunce
    replied
    There should be no difference in BB codes between new threads and new replies. Double check the BB code used in each post to make sure it is the same.

    Leave a comment:

  • DoDeH1
    Senior Member

  • DoDeH1
    started a topic FLV Player for external FLV source problem

    FLV Player for external FLV source problem

    Hello...

    I just made an new bb code with this options:
    Title: Embed FLV Files
    BB Code Tag Name:FLV
    Replacement

    Code:
    <script type="text/javascript" src="embed/swfobject.js"></script>
    <div id="player">"Please refresh page for player"</div> 
    <script type="text/javascript">
    var s1 = new SWFObject('embed/player.swf','mpl','352','201','9');
    s1.addParam('allowscriptaccess','always');
    s1.addParam('allowfullscreen','true');
    s1.addParam('flashvars','&file={param}&frontcolor=#ffffff&screencolor=#000000&controlbar=over&backcolor=#003F86&logo=http://www.dfgrom.com/forums/logo2.png');
    s1.write('player');
    </script>
    Use {option}: No
    Remove Tag If Empty; Yes
    Disable BB Code Within This BB Code: No
    Disable Smilies Within This BB Code: No
    Disable Word Wrapping Within This BB Code: No

    Everything works just fine when I add a new post... The video shows correctly.
    When I try to add a post replay with a video something strange happens. The post replay has no video.
    Can anyone tell me how to fix this problem?

    Thank you

Related Topics

Collapse

Working...
X