Announcement

Collapse
No announcement yet.

database error @ picture.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • database error @ picture.php

    After upgrade to 3.0 version a few minutes later I have 73 database errors sent to my email.

    Please don't tell me that it's because of my web hosting and not the vbulletin's problem.

    Here's the error:



    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections
    /home/talaconheo/www/my-site.net/html/includes/class_core.php on line 311

    MySQL Error :
    Error Number :
    Request Date : Sunday, January 18th 2009 @ 09:32:46 PM
    Error Date : Sunday, January 18th 2009 @ 09:32:46 PM
    Script : http://www.mys-site.net/picture.php?albumid=32&pictureid=963t&thumb=1&dl=
    Referrer : http://www.my-site.net/forums.php
    IP Address : 65.93.197.18
    Username :
    Classname : vB_Database
    MySQL Version :

  • #2
    after posting this post about five minutes later I got more and more errors. Never got this error when I was using 3.7, and after upgrade to 3.8 today I started to received these error message sent to email.
    So sad.
    Please help me to solve.


    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections
    /home/talaconheo/www/my-site.net/html/includes/class_core.php on line 311

    MySQL Error :
    Error Number :
    Request Date : Sunday, January 18th 2009 @ 10:09:42 PM
    Error Date : Sunday, January 18th 2009 @ 10:09:42 PM
    Script : http://www.my-site.net/misc.php?show=ccbmessages
    Referrer : http://www.my-site.net/forums.php
    IP Address : 209.91.40.148
    Username :
    Classname : vB_Database
    MySQL Version :

    Comment


    • #3
      The server has maxed out the number of MySQL connections it allows. This is a server-wide limit, not just your forums. You can try turning persistent connections off in your config.php:

      $config['MasterServer']['usepconnect'] = 0;

      But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

      Here is more info on that error:

      http://dev.mysql.com/doc/refman/5.0/...nnections.html
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Here's my config, by default is =0 and i haven't change to anything yet.

        // ****** MASTER DATABASE PERSISTENT CONNECTIONS ******
        // This option allows you to turn persistent connections to MySQL on or off.
        // The difference in performance is negligible for all but the largest boards.
        // If you are unsure what this should be, leave it off. (0 = off; 1 = on)
        $config['MasterServer']['usepconnect'] = 0;

        Comment


        • #5
          Please see the rest of my message.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X