Announcement

Collapse
No announcement yet.

DATEDIFF und MySQL 4.0.16 Requirements - ls that right? Isn't 4.1.1?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DATEDIFF und MySQL 4.0.16 Requirements - ls that right? Isn't 4.1.1?

    PHP: 4.4.0
    MySQL: 4.0.20
    vBulletin version: 3.8 (upgrade from 3.6.8)
    Style: Default
    Installed hacks:
    • vBadvanced CMPS v.3.1.0
    • vBSEO v.3.2.0
    • vBSEO Sitemap Generator v.2.2
    • vbStopForumSpam v.0.61

    I receive this email:
    Code:
    nvalid SQL:
    SELECT DATEDIFF(NOW(), '2009-01-09 11:23:05') AS DAYS;;
    
    MySQL error         : You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '(NOW(), '2009-01-09 11:23:05') AS DAYS' at line 1
    Number of error     : 1064
    Request data        : Friday, January 16th 2009 @ 11:07:03 AM
    Error data          : Friday, January 16th 2009 @ 11:07:05 AM
    Script              : http://site.org/forum/register.php?do=addmember
    Referrer            : http://site.org/forum/register.php
    IP                  : xx.xx.xx.28
    Username            : Axeleratmmusic
    Class name          : vb_database
    This request in MySQL 4.0.24 lead to same error:
    Code:
    SELECT DATEDIFF(NOW(), '2009-01-09 11:23:05') AS DAYS;;
    DATEDIFF() (http://dev.mysql.com/doc/refman/4.1/...ction_datediff) was added in MySQL 4.1.1.
    vBStyle.ru

  • #2
    The stock code doesn't use DATEDIFF(). That's from a modification.

    Comment


    • #3
      Thanks, i found...
      Product vbStopForumSpam REQUIRES MySQL 4.1.1+
      vBStyle.ru

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X