Announcement

Collapse
No announcement yet.

Bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    If you want to be able to upload files, you will need to leave this on. Otherwise you will need to disable open_basedir on the server.

    Leave a comment:


  • blaze718
    replied
    Aright this fixed it.

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes



    But i have a question should i leave this on forever?
    Is it bad?

    Leave a comment:


  • Steve Machol
    replied
    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /home/mmorpg/tmp

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes


    Also the php.ini setting for 'upload_tmp_dir' may be empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.

    Leave a comment:


  • blaze718
    replied
    Warning: tempnam() : open_basedir restriction in effect. File() is not within the allowed path(s): (/home/mmorpgspot:/usr/lib/php:/usr/local/lib/php:/tmp) in [path]/includes/class_dm_socialgroupicon.php on line 165
    Last edited by blaze718; Thu 15 Jan '09, 5:58pm.

    Leave a comment:


  • Steve Machol
    replied
    What is the exact error?

    Leave a comment:


  • blaze718
    started a topic Bug

    Bug

    When trying to upload an image for the social group icon a PHP error is shown and it is not uploaded.
    Thank you.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X