No announcement yet.

Posts are added to moderation queue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Posts are added to moderation queue


    I'm experiencing quite interesting problem with vBulletin. Some posts in some topics seem to be added to moderation queue regardless of permission being set to "Follow Forum Moderation Rules". Basicly a user who has permission to write post without first being approved by moderator suddenly can write post but the post is invisible before approval.

    This problem appears to be random and not very frequent. I double checked usergroup permissions for forum(s) and everything should be okay but problem is still there.

    I should also mention that this isn't VBulletin 3.8 issue, this also happened with 3.7.


  • #2
    Here's all the places moderation can occur:

    1. Check the overall Usergroup settings for the relevant usergroups and make sure moderation is turned off:

    Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup -> Follow Forum Moderation Rules -> Yes

    2. Check the individual forum settings to make sure moderation is turned off:

    Admin CP -> Forums & Moderators -> Forum Manager -> Edit Forum -> Moderate Posts and Moderate Threads -> No

    3. Check ALL the usergroup permissions for that forum (Forum Permissions). One of the usergroups they are in has Follow Forum Moderation Rules set to 'No'. This needs to be set to 'Yes'.

    Admin CP -> Forums & Moderators -> Forum Permissions -> Follow Forum Moderation Rules

    4. Make sure the Primary usergroup has 'Allow Users to have Member Groups ' set to 'Yes'. Otherwise secondary permissions are not considered.

    If these permissions are all set correctly and you still have this problem, then it is from a modification you made.

    5. If you have the Akismet setting turned on, it could be automatically moderating some posts:

    Admin CP -> vBulletin Options -> Spam Management -> vBulletin Anti-Spam Key Powered by Akismet
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.