Announcement

Collapse
No announcement yet.

Please help with what this means

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help with what this means

    I just upgraded to 3.8 and the upgrade script went perfectly, and I was directed tot he admin panel. However, when I try to open the forum, I get this...

    Warning: require_once(/home/p24l3b8d/includes/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/p24l3b8d/public_html/global.php on line 33

    Fatal error: require_once() [function.require]: Failed opening required '/home/p24l3b8d/includes/init.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/p24l3b8d/public_html/global.php on line 33

    What did I do wrong, and how do I fix it?

    Thanks

  • #2
    That looks like a problem with the include path. Did you specify a path in the includes/config.php file?

    Code:
    	//	******** FULL PATH TO FORUMS DIRECTORY ******
    	//	On a few systems it may be necessary to input the full path to your forums directory
    	//	for vBulletin to function normally. You can ignore this setting unless vBulletin
    	//	tells you to fill this in. Do not include a trailing slash!
    	//	Example Unix:
    	//	  $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    	//	Example Win32:
    	//	  $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = '';
    If you are specifying a path then it looks like the path should be:

    Code:
    	//	******** FULL PATH TO FORUMS DIRECTORY ******
    	//	On a few systems it may be necessary to input the full path to your forums directory
    	//	for vBulletin to function normally. You can ignore this setting unless vBulletin
    	//	tells you to fill this in. Do not include a trailing slash!
    	//	Example Unix:
    	//	  $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    	//	Example Win32:
    	//	  $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = '/home/p24l3b8d/public_html';
    Or try leaving it blank since it usually works fine without the path.

    Comment


    • #3
      I removed your post because the config file contains sensitive info.

      The port is wrong. This code:

      Code:
      $config['MasterServer']['port'] = *****_***
      ;
      Should be replaced with this:

      Code:
      $config['MasterServer']['port'] = 3306;

      Comment


      • #4
        Ok, so I need to change that on the config file, and the reupload it?

        Comment


        • #5
          Yes.

          Comment


          • #6
            Does it matter that my old config file is identical to what I put on the new one? Why the old one worked and the new one does not?

            Comment


            • #7
              No, changed it and reuploaded the config file to includes, and got this.

              Warning: require_once(/home/p24l3b8d/includes/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/p24l3b8d/public_html/global.php on line 33

              Fatal error: require_once() [function.require]: Failed opening required '/home/p24l3b8d/includes/init.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/p24l3b8d/public_html/global.php on line 33

              Comment


              • #8
                Should I include a path in the direct path?

                Comment


                • #9
                  Someone please help, the forum is completely down...

                  Comment


                  • #10
                    That still looks like a pathing problem. Try both an empty path and the path I posted previously to see if either one works.

                    If the old config file works then there must be some difference between them. It is OK to use the old config file if that one works.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X