Announcement

Collapse
No announcement yet.

Attachment permissions of secondary group

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment permissions of secondary group

    Admins:
    50 MB Limit
    Extensions default + .exe, .bat, .reg.

    New usergroup:
    2 MB Limit
    Extensions default.

    When I make an administrator member of this new usergroup (primary: admin, secondary new) then something strange happens.

    I still have the extra extensions but suddenly he ge's a 2 MB attachement limit.

    Basically my questions is: what permissions go first? I understand that if there's a ALLOW - DENY situation deny takes precedence. But when you just got two values (one says A other says B), how does vBulletin decide which settings to apply?
    http://www.nucia.nl/forum/
    The best way to kill malware; is to kill it together.

  • #2
    When multiple usergroups are involved, a 'Yes' permission always overides a 'No' permission if 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group. Same goes for a larger quota.

    Note, the primary group must have 'Allow Users to have Member Groups' to 'Yes'. Otherwise the secondary settings are not applicable.

    Note: In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM


    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I'm sorry Steve but what are you talking about with server configs? The 10 MB works fine. vBulletin suddenly tells that persoon that he can upload only 2 MB, the limit that has been set for the secondary usergroup. My server config is fine and has nothing to do with it. I don't have problems with that. Sorry.

      When multiple usergroups are involved, a 'Yes' permission always overides a 'No' permission if 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group.
      Isn't this kinda insecure? Windows works with YES+NO =NO.

      Same goes for a larger quota.
      Well, apparently it doesn't. The user's primary group has a 10 MB limit and the secondary group 2 MB. However, the user is only allowed to have 2 MB.

      I'm not mad or something but it looks like it just doesn't add up..
      http://www.nucia.nl/forum/
      The best way to kill malware; is to kill it together.

      Comment


      • #4
        The permissions work as I outlined with the default vB code. If 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group, then the secondary permissions are considered and if they are larger than the primary group permissions, then that is what is used.

        If you have this setup right and still have this error, then the only possible cause I know of would be an add-on.

        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I've tried again.

          Admin attachment limit, none.
          Second usergroup attachment limit, 5 MB.


          When I am a secondary member of the second group I can't upload attachements anymore because I'm over quota.
          http://www.nucia.nl/forum/
          The best way to kill malware; is to kill it together.

          Comment


          • #6
            That is definitely not how the default vB permissions work. Have you installed any add-ons?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Do you have this option set to yes on secondary usergroup ?

              Allow Users to have Member Groups (Sets whether or not permissions from the user's member (secondary) user group memberships are inherited or not)
              http://www.acegames.us http://www.crazywap.co.uk

              Comment


              • #8
                Both the admin and the secondary group have set that to 'yes'.
                http://www.nucia.nl/forum/
                The best way to kill malware; is to kill it together.

                Comment


                • #9
                  Originally posted by Eagle Creek View Post
                  Both the admin and the secondary group have set that to 'yes'.
                  Try setting to no on admin and yes on secondary and see if that works for you
                  http://www.acegames.us http://www.crazywap.co.uk

                  Comment


                  • #10
                    I've tried that but then no permissions are applied.

                    My situation:

                    I got
                    A. Admins
                    B. Users.
                    C. Blog posters.

                    I want users not to be able to post to the blog, untill they got the group membership for it.
                    So B has blog permission NO, C has.

                    When I put your option to NO, users still can't post to the blog. When I set it so YES, users can post to the blog. However: since users and blogposters both have a 5 MB attachment limit, as soon as I also join the secondary usergroup I'm limited to 5 MB also.
                    http://www.nucia.nl/forum/
                    The best way to kill malware; is to kill it together.

                    Comment


                    • #11
                      Im unsure then , I have a similar problem right now , I will update if I find the answer
                      http://www.acegames.us http://www.crazywap.co.uk

                      Comment


                      • #12
                        Thanks.
                        http://www.nucia.nl/forum/
                        The best way to kill malware; is to kill it together.

                        Comment


                        • #13
                          Originally posted by Eagle Creek View Post
                          I've tried again.

                          Admin attachment limit, none.
                          Second usergroup attachment limit, 5 MB.


                          When I am a secondary member of the second group I can't upload attachements anymore because I'm over quota.
                          If you have the limit set to 0 in the primary group (unlimited) and then a setting like 5 MB in the secondary group, you will only be allowed 5 MB. They changed that after 3.0. Now you have to set the number to really large to truly be unlimited if you are going to also put them in a secondary group that has a smaller limit.

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools <- awesome site for html/css help

                          Comment


                          • #14
                            Originally posted by Lynne View Post
                            If you have the limit set to 0 in the primary group (unlimited) and then a setting like 5 MB in the secondary group, you will only be allowed 5 MB. They changed that after 3.0. Now you have to set the number to really large to truly be unlimited if you are going to also put them in a secondary group that has a smaller limit.
                            What if my primary usergroup has edited by as no and second user group edited by as yes , how can I make it use the permission from the primary usergroup ?
                            http://www.acegames.us http://www.crazywap.co.uk

                            Comment


                            • #15
                              Originally posted by Lynne View Post
                              If you have the limit set to 0 in the primary group (unlimited) and then a setting like 5 MB in the secondary group, you will only be allowed 5 MB. They changed that after 3.0. Now you have to set the number to really large to truly be unlimited if you are going to also put them in a secondary group that has a smaller limit.
                              So basically what you're saying is I have to give myself a limit of, let's say, 1000 MB and then it works?

                              (I still work with 3.6.8 by the way, planning on upgrading soon)

                              Edit:
                              Just tried it out, it works! Very nice!
                              True, 5MB is more then 0 but when 0 means 'unlimited' I think the forum should be able to understand that, haha.
                              http://www.nucia.nl/forum/
                              The best way to kill malware; is to kill it together.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X