Announcement

Collapse
No announcement yet.

HTML in Usertitles?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HTML in Usertitles?

    I'm now having an issue with HTML within Usertitles ever since I upgraded to 3.8. My moderators like to have scrolling, colored, bold, etc so an Admin normally sets it and selects "Yes, admin set HTML allowed". It worked fine in 3.7 but now we're having to resest them often. Any idea why this is happening now?

  • #2
    Do you mean you edit them in the admin page for the user, and it's fine for a while, but suddenly it disappears?

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Correct, that is exactly what I mean, but it switches to coding all of a sudden. It worked fine in 3.7 though.

      Comment


      • #4
        I am not able to verify this with the default 3.8.0. Can you please explain exactly what you are doing step-by-step so we can try the same thing?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          I am not able to verify this with the default 3.8.0. Can you please explain exactly what you are doing step-by-step so we can try the same thing?
          Sure thing

          Rundown: My moderators want their usertitles to scroll, bold, or even colored.


          1. I go into the admin panel and search for their name.

          2. When their profile appears I set it with this coding (using my Super Mod's usertitle for the example):

          HTML Code:
          <marquee direction=up height=20 scrollamount=1><FONT color=Red>Super Moderator</marquee></FONT>
          3. Where it says Custom User Title I select "Yes, admin set (HTML allowed)" and click save

          It's always worked fine doing it this way on vBulletin 3.7, but now after I save it a little while (anywhere from a a few minutes to a few hours) it will turn into this:

          &lt;marquee direction=up height=20 scrollamount=1&gt;&lt;FONT color=Red&gt;Super Moderator&lt;/marquee&gt;&lt;/FONT&gt;

          That is how it displays around the forum until I go back in there do the steps I posted, again.

          Comment


          • #6
            You know the marquee only works with IE, right?

            Anyway I tested this myself and got no errors. The marquee works with IE but not other browsers. With other browsers I only see 'Super Moderator'.

            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

            Next, disable all plugins.

            Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

            define('DISABLE_HOOKS', true);

            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

            Do you have the same problem?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              You know the marquee only works with IE, right?

              Anyway I tested this myself and got no errors. The marquee works with IE but not other browsers. With other browsers I only see 'Super Moderator'.

              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all plugins.

              Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

              define('DISABLE_HOOKS', true);

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

              Do you have the same problem?
              Yes, I only use IE. That's quite a bit of work especially since I'm new at vBulletin. I will have to just live with the complaints from the moderators. Thanks for all your help though.

              Comment


              • #8
                We had the same issue. We had only html code with an image that worked in both IE and Firefox, but we found that the issue involves when you are using User Set for the User Title. Before we had it set to User Set and the html code was pasted in by admin, but on upgrade, it no longer allowed the html. I had to go in and change everyone to ADMIN only.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X