Announcement

Collapse
No announcement yet.

Invalid SQL during upgrade, unable to

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid SQL during upgrade, unable to

    After the step 5/5 that I cannot complete I read this error, also in email:

    Database error in vBulletin 3.7.4:

    Invalid SQL:

    SELECT prefix.*, prefixpermission.usergroupid AS restriction
    FROM fl_prefix AS prefix
    LEFT JOIN fl_prefixpermission AS prefixpermission ON (prefix.prefixid = prefixpermission.prefixid)
    ORDER BY prefix.displayorder;

    MySQL Error : Illegal mix of collations (latin1_general_ci,IMPLICIT) and (latin1_swedish_ci,IMPLICIT) for operation '='
    Error Number : 1267
    Request Date : Sunday, January 11th 2009 @ 01:11:27 AM
    Error Date : Sunday, January 11th 2009 @ 01:11:27 AM
    Script : http://www.forumlibri.com/forum/inst...0a2.php?step=5
    Referrer : http://www.forumlibri.com/forum/inst...0a2.php?step=4
    IP Address : 82.45.173.96
    Username :
    Classname : vB_Database
    MySQL Version : 5.0.70-log

    How can I solve this?
    Thank you very much

  • #2
    I think I have solved the problem.
    By phpmyadmi I change the attribute COLLATION of table
    fl_prefixpermission

    from
    latin1_swedish_ci
    to
    latin1_general

    I click back on my browser and RE-click on proced to step 5/5 and now it works.

    Have I make a good thing or a big Mistake?

    Thanks!

    Comment

    Related Topics

    Collapse

    Working...
    X