Announcement

Collapse
No announcement yet.

AJAX doesn't work after upgrade to 3.8. Vbseo not installed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    CTRL F5 in Windows, but yes.

    Comment


    • #32
      Originally posted by Zachery View Post
      CTRL F5 in Windows, but yes.
      Yes, of course.

      I've tried this in the first turn when I found this errors... It didn't help.

      Quite strange - some of my users have this issue, but not all of them. These days I'm always thinking of what could cause this, but didn't get to any meaningful results... The only new thing I invented that it could be memcached... But why? And I have no idea how to check this...
      Boris Lifanovsky; administrator of the biggest Russian classical music forum

      Lifanovsky.com | ForumKlassika.Ru

      Comment


      • #33
        Originally posted by lifanovsky View Post
        The gut from the vB support, Zachery
        That seems a little harsh, considering that he's trying to help you.
        Psychlinks Web Services Affordable Web Design & Site Management
        Specializing in Small Businesses and vBulletin/Xenforo Forums

        Comment


        • #34
          Originally posted by djbaxter View Post
          That seems a little harsh, considering that he's trying to help you.
          Gosh, thanks for telling! Of course this was a misspelling! I meant to write "guy" indeed!

          Of course he was trying to help and he was very nice and helpful actually. Zachery, I am so sorry I spelled a wrong letter, really!

          Though, unfortunately I'm still stuck. Nothing helps and I ran out of the ideas. Users on my forum are angry (those who have this problem) but I have nothing to advice them...
          Last edited by lifanovsky; Sun 18 Jan '09, 12:51pm.
          Boris Lifanovsky; administrator of the biggest Russian classical music forum

          Lifanovsky.com | ForumKlassika.Ru

          Comment


          • #35
            Its really hard, seem if you can find some sort of common issue between them. Browser, OS, Firewall, Antivirus, antispyware, and we can work from there.

            Comment


            • #36
              Right, that's what I was trying to do - find something in common. But its hard keeping in mind that in my case in works in IE and it doesn't in FF and Chrome, and another person has it working in FF but in his case it doesn't work in IE. So probably its not browser-dependent. Javascript... its turn on. Also, what is strange - it worked fine in 3.7.4 - and stopped working right after upgrade.

              Another fact - still in my FF I only have problem with my main forum. I tried to instal a test board - no problem there. On this forum everything is fine too. And on some others too. So it has to do with some specific installation...

              Also, people have different firewalls - and even if I turn off mine nothing changes...

              What else...

              Don't get me wrong - I'm not exactly complaining, I'm just trying to keep this topic up to date so that other people who have this problem new something is still going on... On the other hand, maybe there's someone out there who have already solved this problem...
              Boris Lifanovsky; administrator of the biggest Russian classical music forum

              Lifanovsky.com | ForumKlassika.Ru

              Comment


              • #37
                Im having the same issue since upgrading to 3.8

                "Thank you for posting! You will now be taken to your post. If you opted to post a poll, you will now be allowed to do so."


                when quick replying.

                Comment


                • #38
                  We also have this problem with a 3.8 upgrade. We tried it with plugins disabled in the config and the default vBulletin style with no modifications, in FF and IE, also with our cache cleared.

                  Comment


                  • #39
                    Everyone having this problem needs to start their own thread will all the relevant details. Thank you.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #40
                      Steve, while you're, I did start the thread and even had a support ticket carried by Zachery. While he was 100% professional and helpful, he couldn't come up with some sort of a decision or workaround for this problem. I can see that this issue is not wide spread but still exist for number of vb installations. I just wish someone could look into this problem in some advanced way - though it seems to me that vb support doesn't really think its a problem worth mentioning. I will definitely be stick with vB as a base for my forum and I'm sure once upon a time I will solve this problem by myself (all the more that I'm a happy customer for more than 2 years already) - though right now I feel a little stressed and lost. I was always been able to find a solution either by myself or using the support forum - and this is the first time when I feel absolutely stuck...
                      Boris Lifanovsky; administrator of the biggest Russian classical music forum

                      Lifanovsky.com | ForumKlassika.Ru

                      Comment


                      • #41
                        Just now I received PM from Pogo, who gave me a great advice that totally solved this problem in my case. I quote it here. Hope this helps those, who have this problems but don't have vbseo installed. Also I hope developers will find useful Pogo's advice about an additional switch in vB settings.

                        we had one customer with similar problems regarding AJAX functions.
                        In his case it was because his webserver is using mod_deflate to compress XML AJAX responses.

                        To solve this problem he had to comment out the following line in includes/class_xml.php
                        PHP Code:
                            /**
                            * Sends the content length header
                            */
                            
                        function send_content_length_header()
                            {
                                
                        //@header('Content-Length: ' . $this->fetch_xml_content_length());
                            

                        Change
                        @header('Content-Length: ' . $this->fetch_xml_content_length());
                        to
                        //@header('Content-Length: ' . $this->fetch_xml_content_length());

                        Perhaps you want to comment out this line as well and test if it solves your problem.
                        If it helps please let me know about it. I think vBulletin should get a setting then to disable this code for specific server settings.
                        Boris Lifanovsky; administrator of the biggest Russian classical music forum

                        Lifanovsky.com | ForumKlassika.Ru

                        Comment


                        • #42
                          So good to see you got this resolved and thanks to Pogo for the solution and to you for sharing it in this thread. Hopefully this helps others that have the same problem.

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools <- awesome site for html/css help

                          Comment


                          • #43
                            Thanks, Lynne. I also wish vB developers would comment this somehow. Since it look like vB support could have been able to advice me this - but they had no idea about this solution. Maybe Pogo is right and there should be some additional switch in CP...
                            Last edited by lifanovsky; Fri 23 Jan '09, 3:03am.
                            Boris Lifanovsky; administrator of the biggest Russian classical music forum

                            Lifanovsky.com | ForumKlassika.Ru

                            Comment


                            • #44
                              My QUICK REPLY NOW WORKS

                              Originally posted by lifanovsky View Post
                              Just upgraded to 3.8. Everything went fine. With one exception. All the AJAX features (quick reply, edit tags, reputation etc. don't work).

                              I have never installed vbseo so this is not the issue for me. Also I tried to disable all hack and browsed the forum with original templates and English language. Everything is the same. Tried to re-upload files - doesn't help either.

                              This only happed after upgrade - everything was fine before. I also didnt to anything to the server.

                              I have vb 3.8 (obviously! ), Apache v1.3.37, PHP 5.2.1, MySQL 5.1.16.

                              Please help!
                              I had this problem with quick reply and went here per Steve:

                              1. The quick reply settings are here:

                              Admin CP -> vBulletin Options -> Message Posting and Editing Options -> Quick Reply

                              I had it set to Yes, but it didn't work. I think I changed it to no or the other option.

                              I am having troulbe getting adsense, my domain and vB to all play together. Anyone dealt with that before?

                              Confused as usual.

                              Comment


                              • #45
                                Just throwing this information in as well. Upgraded to 3.8.0 and had AJAX issues with:

                                Standard Functions:
                                - Inline Post Editing
                                - Quick Reply on Member Profiles (works if you press Post Message twice)
                                - Quick Reply on Social Groups (works if you press Post Message twice)

                                Mod Functions (I believe they don't work b/c of the AJAX issue)
                                - (vMoods) Mood Manager (link)
                                - New Posts w/ Inline New Post count in NavBar (link)

                                Steps I've tried to attempt a resolution:
                                - Uninstall all mods
                                - Reupload the default vB 3.8 files (I hadn't changed any but just to make sure in case something didn't get copied over from the upgrade)
                                - vBSEO was never installed (just noting...)

                                I tried testing a fresh installation on another site on a different server and everything worked including the mods. (It's down now..) So, I've come to conclude on my own it must be a server configuration issue with the new version. I activated the phpinfo function and noted I'm running PHP 5.25.5 and MySQL 4.1.21. I've requested my web host upgrade both to the latest version, and if there is still an issue I'll open a support ticket here.
                                Last edited by Theater; Mon 26 Jan '09, 12:05am.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X