Announcement

Collapse
No announcement yet.

Allowed memory size of 16777216 bytes exhausted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Allowed memory size of 16777216 bytes exhausted

    I get this error code when I click on a member name.

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 160038 bytes) in /chroot/home/blackeni/blackenize.com/html/forums/member.php(514) : eval()'d code on line 284

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 384 bytes) in /chroot/home/blackeni/blackenize.com/html/forums/includes/functions_newpost.php on line 1792

  • #2
    This error is from a plugin you've installed. You need to disable each of your plugins then turn one at a time to see which one is causing this.

    If you cannot log into the Admin CP then to disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    This will disable all hooks and allow you to log in properly with no hooks running.

    http://www.vbulletin.com/docs/html/disable_plugins
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      i would like to also suggest the option of requesting your host increase their server PHP memory limit. this would also fix that error. its basically saying:

      "a PHP file on this server is limited to 16777216 bytes, you attempted to use 384 bytes more than your limit"

      16MB is awfully low.. my host usually keeps his at 128MB (and will up if need be.. (did for me if i recall))

      Comment


      • #4
        Increasing the memory_limit might help but the underlying error is due to an add-on.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          thank you.

          I changed the php.ini file and it resolved the issue.
          Last edited by blackenizer; Wed 17 Dec '08, 8:13pm.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X