Announcement

Collapse
No announcement yet.

social groups template issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • social groups template issue

    after i upgraded to 3.8.0 RC1 i got a problem (see attached file)

    my template look like this:

    Code:
    $stylevar[htmldoctype]
    <html xmlns="http://www.w3.org/1999/xhtml" dir="$stylevar[textdirection]" lang="$stylevar[languagecode]">
    <head>
    $headinclude
    <title>$vboptions[bbtitle] - $custompagetitle</title>
    $socialgroups_css
    </head>
    <body>
    $header
    $navbar
    
    <form action="group.php?$session[sessionurl]do=grouplist" method="post">
    <table class="tborder" id="sg_grouplist" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" style="clear: both">
    <tr>
        <td class="tcat" width="100%" colspan="6">
            <div style="float:$stylevar[right]" class="normal">$vbphrase[search_groups] <input type="text" class="bginput" name="filtertext" value="$filters[text]" style="font-size: 11px;" />&nbsp;<input type="submit" class="button" value="$vbphrase[go]" /></div>
            $grouplisttitle
            <if condition="$category_name">
                <span style="font-weight:normal"><phrase 1="$category_name">$vbphrase[in_category_x]</phrase></span>
            </if>
        </td>
    </tr>
    <if condition="$grouplist">
        <tr>
            <td class="thead" width="100%">
                <if condition="$show['category_names']"><span style="float:$stylevar[right]"><a href="$orderlinks[category]">$vbphrase[category]</a> $sortarrow[category]</span></if>
                <a href="$orderlinks[name]">$vbphrase[group_name]</a> $sortarrow[name]
            </td>
            <td class="thead" align="center" nowrap="nowrap">
                <a href="$orderlinks[members]">$vbphrase[group_members]</a> $sortarrow[members]
            </td>
            <if condition="$show['gminfo']">
                <td class="thead" align="center" nowrap="nowrap">
                    <a href="$orderlinks[discussions]">$vbphrase[discussions]</a> $sortarrow[discussions]
                </td>
                <td class="thead" align="center" nowrap="nowrap">
                <a href="$orderlinks[messages]">$vbphrase[messages]</a> $sortarrow[messages]
                </td>
            </if>
            <if condition="$show['pictureinfo']"><td class="thead" align="center" nowrap="nowrap">
                <a href="$orderlinks[pictures]">$vbphrase[pictures]</a> $sortarrow[pictures]
            </td></if>
            <if condition="$show['gminfo']"><td class="thead" align="center" nowrap="nowrap">
                <a href="$orderlinks[lastpost]">$vbphrase[last_post]</a> $sortarrow[lastpost]
            </td></if>
        </tr>
        $grouplist
        <else />
        <tr>
            <td class="alt1" align="center" colspan="6">$vbphrase[no_groups_to_display]</td>
        </tr>
    </if>
    
    <tr>
        <td colspan="6" align="center" class="tfoot smallfont">
            <strong><a href="group.php?$session[sessionurl]do=search">$vbphrase[advanced_search]</a></strong>
             &nbsp;
            <strong><a href="groupsubscription.php?$session[sessionurl]">$vbphrase[subscribed_discussions]</a></strong>
        </td>
    </tr>
    </table>
    
    <input type="hidden" name="s" value="$session[sessionhash]" />
    <input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />
    <input type="hidden" name="dofilter" value="1" />
    </form>
    
    <br />
    
    <div class="floatcontainer">
        <if condition="$pagenav">
        <div id="discussion_pagenav">
            $pagenav
        </div>
        </if>
    
        <if condition="$show['creategroup']">
        <div class="action_links">
            <a href="group.php?$session[sessionurl]do=create" rel="nofollow">$vbphrase[create_a_new_group]</a>
        </div>
        </if>
    </div>
    
    $footer
    </body>
    </html>
    can somebody help me to fix this ?
    Attached Files

  • #2
    got it, was group.php file from vbulletin 3.8.0 RC1

    i took the old file from 3.7.4 PL1

    now it works. maybe you have to correct the new group.php file...

    Comment


    • #3
      You should report that in the bugs section if it is a bug is that it can be assessed and if necessary fixed for next release.
      Last edited by athlon64bit; Fri 5 Dec '08, 12:09pm.

      Comment


      • #4
        Originally posted by Playa82 View Post
        now it works. maybe you have to correct the new group.php file...
        You need to revert you templates so that it is up to date.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Originally posted by Wayne Luke View Post
          You need to revert you templates so that it is up to date.
          i already did that, it doesn't work. only with my old group.php

          Comment


          • #6
            Errors such as this are usually caused by editing files, corrupt files or addons. Please follow these steps to diagnose the issue.

            Please follow these instructions:

            1 - Re-upload all the original vB non-image files (except install.php). These files include all files with the extensions of PHP, JS and CSS. Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

            2 - If that didn't solve the problem, then please disable all plugins.

            Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

            define('DISABLE_HOOKS', true);

            3 - If you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Now check again.

            If you still have the same problem please let me know.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Wayne, try editing footer template and remove this

              HTML Code:
              <div class="smallfont" align="center">$vbphrase[all_times_are_gmt_x_time_now_is_y]</div>
              <br />
              Now go back to the social groups page using firefox, chrome or Safary and see what happens, its the same problem Playa82 its getting.

              The question is, how can I remove the code above from the footer template without messing the social groups page? because I need to remove that code and move it bellow or anywhere else.

              I tested it with a new installation of vB 3.8.0 RC 2, without modifications.

              Internet explorer is not affected

              EditedI found this erros in the css, the original CSS for the social groups, but after correcting the problem persist, I don't know what else to do...

              in socialgroups_css
              HTML Code:
              #discussion_moderation, .discussion_tools {
              	float: $stylevar[right];
              	text-align: $stylevar[left];
              	clear: $stylevar[right];
              	white-spcae: nowrap;
              }
              .social_group .vbmenu_control {
              	text-align: $stylevar[left];
              	float: $stylevar[right];
              	background: none;
              	padding: $stylevar[cellpadding]px 0px;
              	margin: $stylevar[right]px;
              }
              
              .social_group .vbmenu_control {
              	text-align: $stylevar[left];
              	float: $stylevar[right];
              	background: none;
              	padding: $stylevar[cellpadding]px 0px;
              	margin: $stylevar[right];
              }
              That's vbulletin code, not my code. You need to fix those typos, margin: $stylevar[right]px and white-spcae: nowrap; AND margin: $stylevar[right];

              maybe the solution is fixing this line: margin: $stylevar[right];
              what's the value for that?
              Last edited by Elmer; Mon 22 Dec '08, 10:52pm.

              Comment


              • #8
                If you want to remove the date, replace

                HTML Code:
                <div class="smallfont" align="center">$vbphrase[all_times_are_gmt_x_time_now_is_y]</div>
                <br />
                
                $spacer_close
                <!-- /content area table -->
                
                <form action="$vboptions[forumhome].php" method="get">
                with

                HTML Code:
                &nbsp;
                <br />
                
                $spacer_close
                <!-- /content area table -->
                
                <form action="$vboptions[forumhome].php" method="get" style="clear:left">

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X