Announcement

Collapse
No announcement yet.

Database error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error

    With beta 2

    Database error in vBulletin 3.8.0 Beta 2:

    Invalid SQL:

    DELETE FROM gbl_access
    WHERE forumid IN () AND
    userid = 173;

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND
    userid = 173' at line 2
    Error Number : 1064
    Request Date : Saturday, November 8th 2008 @ 12:02:52 AM
    Error Date : Saturday, November 8th 2008 @ 12:02:52 AM
    Script : http://globaldesiz.com/forum/cron.php?rand=1226127770
    Referrer : http://globaldesiz.com/forum/forumdisplay.php?f=2
    IP Address : 72.138.30.78
    Username : Unregistered
    Classname : vB_Database
    MySQL Version :

  • #2
    Errors such as this are usually caused by editing files, corrupt files or addons. Please follow these steps to diagnose the issue.

    Please follow these instructions:

    1 - Re-upload all the original vB non-image files (except install.php). These files include all files with the extensions of PHP, JS and CSS. Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    2 - If that didn't solve the problem, then please disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    3 - If you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Now check again.

    If you still have the same problem please let me know.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X