Announcement

Collapse
No announcement yet.

Planning to upgrade 3.8.7 PL5 to 3.8.11 - order of PHP upgrades?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Planning to upgrade 3.8.7 PL5 to 3.8.11 - order of PHP upgrades?

    Hi all -

    I have an older forum sitting at 3.8.7 PL5 for years, and I have some time this week to work on upgrades. Would like to take it to 3.8.11, not interested in moving this forum to 4.x or beyond. My PHP on that server is 5.4.45, mysql is at 5.5.62 (all on a Centos 6.10 box, otherwise reasonably patched at the OS level). I believe I need to update PHP to 5.6, but mysql should be OK. What is the recommended order for these upgrades, for the install to go as smoothly as possible? Do I first update vbulletin all the way to 3.8.11, or do I need to update PHP first in order for the vbulletin upgrade to work properly? (apologies for the basic question, but have been searching on this site and elsewhere for awhile and haven't found a clear gameplan yet).
    Last edited by aciurczak; Tue 25th Dec '18, 2:29am.
    www.montgomerybikers.com / www.ninjette.org / www.cal24.com

  • #2
    Upgrade php to 5.6 first, them upgrade vBulletin to 3.8.11.

    You'll need to do this in quick succession, as once you upgrade php your live site may break until it is upgraded.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Appreciate it, thx. In your opinion - is going to the latest supported PHP 5.6.39 (released Dec 2018) less error prone than trying to take it all the way to PHP 7.1? The site isn't terribly customized, but I do have a few plug-ins that I'd really like to avoid troubleshooting at this point.
      www.montgomerybikers.com / www.ninjette.org / www.cal24.com

      Comment


      • #4
        If you have plugins, stick with php 5.6.
        Many older plugins won’t run on later versions of php.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.6 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Ack - I just saw this:

          https://www.vbulletin.com/forum/foru...n-3-8-11/page3

          I am using the standard vb blog add-on on this site. It looks like if I update to PHP 5.6, it will cause issues. So realizing that there's no perfect answer when dealing with older software like this, I need to find the best path forward.

          from the download area:
          vBulletin 3.8.11 requires PHP 5.6.0+ and MySQL 5.5.8+.
          vBulletin 3.8.10 requires PHP 5.5.0+ and MySQL 5.0.0+.
          vBulletin 3.8.9 requires PHP 5.3.0+ and MySQL 4.1.0+.
          vBulletin 3.8.7 and 3.8.8 require PHP 5.2.0+ and MySQL 4.0.16+.

          So it looks like I need to find out the latest PHP version that won't break the blog, update it to that, and then update vBulletin itself to either 3.8.10 (if blog breaks at PHP 5.5), or just 3.8.9 and call it a day.
          www.montgomerybikers.com / www.ninjette.org / www.cal24.com

          Comment


          • #6
            If you're using the vBulletin Blog addon, your path forward should be to upgrade to the vBulletin 4 Publishing Suite or vBulletin 5. You already have the licenses to upgrade to vBulletin 4 on your account.

            The process would be the same.

            1) Put your forum into Maintenance mode.
            2) Upgrade PHP.
            3) Upgrade to vBulletin 4.2.5.

            Using PHP 7.1 would be sufficient if you're not using third-party addons. If you're using third-party addons then you will need to see if they have updated versions for the newer versions of PHP or disable them.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Understood. I moved another of my forums to 4.X, and had a pretty terrible experience. Some of that was due to the changes in 4 itself, some of it was due to lack of add-ons that both myself and my members are fond of. It doesn't look like there is any "easy button" for me to get current on security patches, without a pretty cumbersome upgrade/migration for my overall forum. In the meantime, is there any guidance on what version of PHP breaks the VB Blog 2.0.6? Does it break when PHP goes to 5.5, or after it goes to 5.6? (I realize this may be a shot in the dark).
              www.montgomerybikers.com / www.ninjette.org / www.cal24.com

              Comment


              • #8
                PHP 5.6 introduced some pretty fundamental changes to how class objects are created in the code along with referencing variables. This is what causes the issue when upgrading.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X