No announcement yet.

Error connecting to database after PHP & mySQL upgrade - vBulletin upgrade to 3.8.11

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error connecting to database after PHP & mySQL upgrade - vBulletin upgrade to 3.8.11

    I was running vBulletin 3.8.4 and PHP 5.2.17 and mySQL 5.1.73.

    I'm upgrading it all at the same time, so I backed up my DB, made a backup copy on my server, then uploaded all the new vb 3.8.11 files in preparation to upgrade. I then had my web host upgrade to PHP 5.6.31 and MariaDB 10. They had to wipe the server completely and restore all my sites because they upgraded the OS and cPanel at the same time.

    So now I'm ready to actually start the vb upgrade script, but I get a database error:
    Database error in vBulletin :
    mysqli_real_connect(): (HY000/1045): Access denied for user 'xxxxx'@'localhost' (using password: YES)
    /home/xxxxx/public_html/forums/includes/class_core.php on line 1210
    MySQL Error   : 
    Error Number  : 
    Request Date  : Tuesday, August 8th 2017 @ 12:50:13 PM
    Error Date    : Tuesday, August 8th 2017 @ 12:50:13 PM
    Script        : http://xxxxx/forums/install/upgrade.php
    Referrer      : 
    IP Address    : IPADDRESS
    Username      : 
    Classname     : vB_Database_MySQLi
    MySQL Version : 
    Server        : xx.xx.xx.xx
    User Agent    :
    I was able to connect to this database before the PHP upgrade, so I know my config.php settings are correct. I've already tried changing the password on my database to match what I know it was before (in case something in the restore changed it). I've also unassigned and reassigned my mysql user to the database in case that connection got broken somehow.

    It sure feels like a password or user problem, but all seems correct.

    Thanks for any suggestions.

  • #2
    I got it. It was something stupid. For my database username I didn't include the full thing with underscore (ie. cpaneluser_mysqluser) Now that I changed that it's working and the upgrade script is humming along.

    For 10+ years I've only used the last part of the username (the "mysql username, without the _) in my config files and it's worked just fine. My host says it's a change with EA4 from cPanel.


    Related Topics